summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTest User2020-03-09 10:41:30 -0600
committerTest User2020-03-09 10:41:30 -0600
commit8774a2f9ff0ce1bf6458ef75edc4736afb650b1b (patch)
treed36f084eaeec5d3bb6d475c3ac55d96e8ec2108c
parent80bda83254b00bd048756f45b440258d23d02f29 (diff)
downloadaur-8774a2f9ff0ce1bf6458ef75edc4736afb650b1b.tar.gz
update dependencies, add verbose flag for dep / go
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b799c37fc616..639647b3372c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall.
pkgver = 1.0.0rc6.r0.27778c1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gustavo-iniguez-goya/opensnitch
install = opensnitch.install
arch = i686
@@ -11,9 +11,11 @@ pkgbase = opensnitch-git
makedepends = dep
makedepends = go-pie
makedepends = python-setuptools
+ makedepends = python-grpcio-tools
depends = libnetfilter_queue
depends = libpcap
- depends = python-protobuf-compiler
+ depends = python-grpcio
+ depends = python-protobuf
depends = python-pyinotify
depends = python-unicode-slugify
depends = python-pyqt5
diff --git a/PKGBUILD b/PKGBUILD
index 1a33ec1c005c..4c11a6a369c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=opensnitch-git
pkgver=1.0.0rc6.r0.27778c1
-pkgrel=2
+pkgrel=3
pkgdesc="A GNU/Linux port of the Little Snitch application firewall."
arch=('i686' 'x86_64')
url="https://github.com/gustavo-iniguez-goya/opensnitch"
license=('GPL3')
-makedepends=('git' 'dep' 'go-pie' 'python-setuptools')
-depends=('libnetfilter_queue' 'libpcap' 'python-protobuf-compiler'
+makedepends=('git' 'dep' 'go-pie' 'python-setuptools' 'python-grpcio-tools')
+depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
'python-pyinotify' 'python-unicode-slugify' 'python-pyqt5'
'python-libconfigparser' 'logrotate')
optdepends=('logrotate: for logfile rotation support')
@@ -33,7 +33,7 @@ prepare() {
export GOPATH="$srcdir"/gopath
cd "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}/daemon"
- dep ensure
+ dep ensure -update -v
cd "$srcdir/${pkgname%-git}"
sed -i 's|local/bin|bin|g' daemon/opensnitchd.service
@@ -44,6 +44,7 @@ build() {
cd "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}/daemon"
go build \
+ -v \
-trimpath \
-ldflags "-extldflags $LDFLAGS" \
-o opensnitchd .