summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlsf2018-10-11 00:37:33 +0200
committerlsf2018-10-11 00:37:33 +0200
commit8a7b0f5b0f0a6899f20db41abc2f378e197afe1e (patch)
tree94f2a77b5335eb237e705ab72019200758ee726a
parent2f2490237122dd7468e74e8ca32a39975f4cbec8 (diff)
downloadaur-8a7b0f5b0f0a6899f20db41abc2f378e197afe1e.tar.gz
pwuid issue got fixed upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--pwuid.patch13
3 files changed, 7 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6e4e49f641d..1a7728420916 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall.
- pkgver = 20180913.350_e9c10b9
- pkgrel = 3
+ pkgver = 20181008.359_c10e7a3
+ pkgrel = 2
arch = i686
arch = x86_64
license = GPL
@@ -22,10 +22,8 @@ pkgbase = opensnitch-git
provides = opensnitch-ui
source = git://github.com/evilsocket/opensnitch.git
source = nosudo.patch
- source = pwuid.patch
md5sums = SKIP
md5sums = eb5a6c83c3816220799e678e32572705
- md5sums = 03a48a1be821e80a64b7d392cc12db4b
pkgname = opensnitch-git
diff --git a/PKGBUILD b/PKGBUILD
index 82666c3429a2..8040c620d813 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lsf
-# Maintainer: Adam Hose <adis@blad.is>
-pkgver=20180913.350_e9c10b9
-pkgrel=3
+# Contributor: Adam Hose <adis@blad.is>
+pkgver=20181008.359_c10e7a3
+pkgrel=2
_pkgname=opensnitch
pkgname=opensnitch-git
arch=('i686' 'x86_64')
@@ -16,12 +16,10 @@ depends=('python-grpcio' 'python-grpcio-tools' 'python-pyinotify'
provides=('opensnitch' 'opensnitch-ui')
source=("git://github.com/evilsocket/opensnitch.git"
- 'nosudo.patch'
- 'pwuid.patch')
+ 'nosudo.patch')
md5sums=('SKIP'
- 'eb5a6c83c3816220799e678e32572705'
- '03a48a1be821e80a64b7d392cc12db4b')
+ 'eb5a6c83c3816220799e678e32572705')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -51,7 +49,6 @@ build() {
dep ensure
cd "$GOPATH/src/opensnitch"
patch -Np1 -i "${srcdir}/nosudo.patch"
- patch -Np1 -i "${srcdir}/pwuid.patch"
make
}
diff --git a/pwuid.patch b/pwuid.patch
deleted file mode 100644
index 18fe239de288..000000000000
--- a/pwuid.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/ui/opensnitch/dialogs/stats.py b/ui/opensnitch/dialogs/stats.py
-index 738363b..40d2a99 100644
---- a/ui/opensnitch/dialogs/stats.py
-+++ b/ui/opensnitch/dialogs/stats.py
-@@ -202,7 +202,7 @@ class StatsDialog(QtWidgets.QDialog, uic.loadUiType(DIALOG_UI_PATH)[0]):
- if self._address is None:
- for uid, hits in self._stats.by_uid.items():
- try:
-- pw_name = pwd.getpwall(int(uid)).pw_name
-+ pw_name = pwd.getpwuid(int(uid)).pw_name
- except KeyError:
- pw_name = "(UID error)"
- finally: