summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-06-10 08:59:19 -0600
committerMark Wagie2020-06-10 08:59:19 -0600
commit8d457b0f75d852054203a006564d067b4c680aa8 (patch)
treeb0540a26ace29d49a91535567efee44d450b578c
parent5cc2706d8b754c7a5839ed7e94da84a93ab809ba (diff)
downloadaur-8d457b0f75d852054203a006564d067b4c680aa8.tar.gz
adjust go flags
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81b461358f67..b00cc33a48bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opensnitch-git
pkgdesc = A GNU/Linux port of the Little Snitch application firewall.
- pkgver = 1.0.0rc6.r4.0c68365
+ pkgver = 1.0.0rc9.r21.1aa65b9
pkgrel = 1
url = https://github.com/gustavo-iniguez-goya/opensnitch
install = opensnitch.install
@@ -9,7 +9,7 @@ pkgbase = opensnitch-git
license = GPL3
makedepends = git
makedepends = dep
- makedepends = go-pie
+ makedepends = go
makedepends = python-setuptools
makedepends = python-grpcio-tools
depends = libnetfilter_queue
diff --git a/PKGBUILD b/PKGBUILD
index 6f5dc42cc11e..8fdfbfd3767b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Adam Hose <adis@blad.is>
pkgname=opensnitch-git
-pkgver=1.0.0rc6.r4.0c68365
+pkgver=1.0.0rc9.r21.1aa65b9
pkgrel=1
pkgdesc="A GNU/Linux port of the Little Snitch application firewall."
arch=('i686' 'x86_64')
url="https://github.com/gustavo-iniguez-goya/opensnitch"
license=('GPL3')
-makedepends=('git' 'dep' 'go-pie' 'python-setuptools' 'python-grpcio-tools')
+makedepends=('git' 'dep' 'go' 'python-setuptools' 'python-grpcio-tools')
depends=('libnetfilter_queue' 'libpcap' 'python-grpcio' 'python-protobuf'
'python-pyinotify' 'python-unicode-slugify' 'python-pyqt5')
optdepends=('logrotate: for logfile rotation support')
@@ -43,31 +43,28 @@ build() {
cd "gopath/src/github.com/gustavo-iniguez-goya/${pkgname%-git}/daemon"
go build \
- -v \
- -trimpath \
- -ldflags "-extldflags $LDFLAGS" \
- -o opensnitchd .
+ -v \
+ -trimpath \
+ -buildmode=pie \
+ -ldflags "-extldflags \"${LDFLAGS}\"" \
+ -o opensnitchd .
cd "$srcdir/${pkgname%-git}/proto"
make
cd "$srcdir/${pkgname%-git}/ui"
python setup.py build
-
- # Skipping, too many syntax errors
- # cd "$srcdir/${pkgname%-git}"
- # python make_ads_rules.py
}
package() {
cd "$srcdir/${pkgname%-git}"
install -Dm755 daemon/opensnitchd -t "$pkgdir/usr/bin"
install -Dm644 daemon/opensnitchd.service -t \
- "$pkgdir/usr/lib/systemd/system"
+ "$pkgdir/usr/lib/systemd/system"
install -dm755 "$pkgdir/etc/opensnitchd/rules"
install -Dm644 daemon/default-config.json -t "$pkgdir/etc/opensnitchd"
install -Dm644 debian/opensnitch.logrotate \
- "$pkgdir/etc/logrotate.d/opensnitch"
+ "$pkgdir/etc/logrotate.d/opensnitch"
cd "$srcdir/${pkgname%-git}/ui"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build