summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-03-17 22:36:28 +0100
committerCarsten Teibes2014-03-17 22:36:28 +0100
commit02435e48ee0cf90eaf78b856bf58e787b05da5a4 (patch)
tree1514e7a0ca7149510a2bbc52fb93dc33c902db0a
downloadaur-02435e48ee0cf90eaf78b856bf58e787b05da5a4.tar.gz
[add] opensonic 0.1.4
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--opensonic.desktop7
-rw-r--r--opensonic.install13
-rw-r--r--opensonic.sh3
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87eb5fef769e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = opensonic
+ pkgdesc = Game based on the Sonic the Hedgehog universe.
+ pkgver = 0.1.4
+ pkgrel = 6
+ url = http://opensnc.sourceforge.net/
+ install = opensonic.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = allegro4
+ depends = libpng
+ source = http://downloads.sourceforge.net/project/opensnc/Open%20Sonic/0.1.4/opensnc-src-0.1.4.tar.gz
+ source = opensonic.desktop
+ source = opensonic.sh
+ source = http://arch.carsten-teibes.de/aur-stuff/opensonic-loadpng.tar.xz
+ sha256sums = 3a4c3fa9538ee27c04b5ea848c9ad0a83f335471936d4617a18d3648c42588e9
+ sha256sums = 8649e72ba9eb3e01da81671c9c849a6823ccd4f022819e8b57d24abdaa691b06
+ sha256sums = a7ed81118fea52c8ce60a8538e92b6121da3b3358c41d1e6d370ada83cef8740
+ sha256sums = 9681cf2519b5217149dababbc67ae0280d454a59b3b46ec36c0c9e843a554e36
+
+pkgname = opensonic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2336ad20281e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Anton Larionov <diffident dot cat at gmail dot com>
+# Contributor: Dany Martineau <dany.luc.martineau gmail com>
+# Contributor: Tom Boshoven <tomboshoven at gmail dot com>
+
+pkgname=opensonic
+pkgver=0.1.4
+pkgrel=6
+pkgdesc="Game based on the Sonic the Hedgehog universe."
+arch=('i686' 'x86_64')
+url="http://opensnc.sourceforge.net/"
+license=('GPL')
+depends=('allegro4' 'libpng')
+makedepends=('cmake')
+install=opensonic.install
+source=("http://downloads.sourceforge.net/project/opensnc/Open%20Sonic/$pkgver/opensnc-src-$pkgver.tar.gz"
+ "$pkgname.desktop"
+ "$pkgname.sh"
+ "http://arch.carsten-teibes.de/aur-stuff/$pkgname-loadpng.tar.xz")
+sha256sums=('3a4c3fa9538ee27c04b5ea848c9ad0a83f335471936d4617a18d3648c42588e9'
+ '8649e72ba9eb3e01da81671c9c849a6823ccd4f022819e8b57d24abdaa691b06'
+ 'a7ed81118fea52c8ce60a8538e92b6121da3b3358c41d1e6d370ada83cef8740'
+ '9681cf2519b5217149dababbc67ae0280d454a59b3b46ec36c0c9e843a554e36')
+
+build() {
+ cd loadpng
+ cmake .
+ make
+
+ cd ../opensnc-src-$pkgver
+ # add folder of loadpng.a (extracted from configure script)
+ export _ALLEGRO_LIBS="-L$srcdir/loadpng $(allegro-config --libs)"
+ export _ALLEGRO_VERSION="$(allegro-config --version)"
+ # fix broken linking
+ export LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
+ cmake .
+ make
+}
+
+package() {
+ cd opensnc-src-$pkgver
+
+ make DESTDIR="$pkgdir/" install
+ install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 ../$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 icon.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+}
diff --git a/opensonic.desktop b/opensonic.desktop
new file mode 100644
index 000000000000..3aaa63cf70ec
--- /dev/null
+++ b/opensonic.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=OpenSonic
+Exec=opensonic
+Icon=opensonic
+Comment=Game based on the "Sonic the Hedgehog" universe
+Categories=Game;ArcadeGame;
diff --git a/opensonic.install b/opensonic.install
new file mode 100644
index 000000000000..a977b921743e
--- /dev/null
+++ b/opensonic.install
@@ -0,0 +1,13 @@
+
+post_install() {
+ touch usr/share/opensonic/logfile.txt
+ chmod 777 usr/share/opensonic/logfile.txt
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm usr/share/opensonic/logfile.txt
+}
diff --git a/opensonic.sh b/opensonic.sh
new file mode 100644
index 000000000000..61f082a40392
--- /dev/null
+++ b/opensonic.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/share/opensonic/opensonic