summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Marshall2016-06-08 17:24:14 -0400
committerWill Marshall2016-06-08 17:24:14 -0400
commitda85b53ba28c4ef43fb2210bd7e5a799839d4cea (patch)
tree2760e04f8eab5003b80cd0ac745b426a75d44201
downloadaur-da85b53ba28c4ef43fb2210bd7e5a799839d4cea.tar.gz
Recreated package from AUR3
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..058939bae788
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = openspin-git
+ pkgdesc = Open Source SPIN interpreter for the ParallaxⓇ Propeller. Git Version
+ pkgver = VERSION
+ pkgrel = 1
+ url = https://github.com/parallaxinc/OpenSpin
+ arch = x86_64
+ arch = i686
+ license = unknown
+ makedepends = git
+ provides = openspin
+ conflicts = openspin
+ source = openspin::git+https://github.com/parallaxinc/OpenSpin
+ md5sums = SKIP
+
+pkgname = openspin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29a1b3e7b9f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Will Marshall <wcm64@case.edu>
+# Past Maintainer: Matthias Riegler <riegler.matthias2@gmail.com>
+pkgname=openspin-git
+pkgver=VERSION
+pkgrel=1
+pkgdesc="Open Source SPIN interpreter for the ParallaxⓇ Propeller. Git Version"
+arch=('x86_64' 'i686')
+url="https://github.com/parallaxinc/OpenSpin"
+license=('unknown')
+groups=()
+depends=()
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('openspin::git+https://github.com/parallaxinc/OpenSpin')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING git SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm 755 build/openspin "${pkgdir}/usr/bin/openspin"
+}