summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2016-07-13 08:41:26 +0200
committerChristian Hesse2016-07-13 08:41:26 +0200
commit4df393a4a9ab3ed67b72627388df6694ce7cf852 (patch)
tree445884ed866f5e6e7d741aa25f77fb501d42c1d8
parent796fb740d56d51354e228f2cf1c8258e06890101 (diff)
downloadaur-4df393a4a9ab3ed67b72627388df6694ce7cf852.tar.gz
commit openssh-git 7.2.P1.r126.g6310ef2-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
-rw-r--r--install10
-rw-r--r--sshdgenkeys.service2
4 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ead8a1acb4c..ca672ea695bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Tue Feb 16 17:07:23 UTC 2016
+# Wed Jul 13 06:41:26 UTC 2016
pkgbase = openssh-git
pkgdesc = Free version of the SSH connectivity tools
- pkgver = 7.1.P1.r189.g5ac712d
+ pkgver = 7.2.P1.r126.g6310ef2
pkgrel = 1
url = http://www.openssh.org/portable.html
- install = install
arch = i686
arch = x86_64
license = custom:BSD
@@ -29,7 +28,7 @@ pkgbase = openssh-git
source = sshd.conf
source = sshd.pam
sha256sums = SKIP
- sha256sums = ff3cbdd0e59ff7dac4dc797d5c0f2b1db4117ddbb49d52f1c4f1771961903878
+ sha256sums = 4031577db6416fcbaacf8a26a024ecd3939e5c10fe6a86ee3f0eea5093d533b7
sha256sums = 69cc2abaaae0aa8071b8eac338b2df725f60ce73381843179b74eaac78ba7f1d
sha256sums = c5ed9fa629f8f8dbf3bae4edbad4441c36df535088553fe82695c52d7bde30aa
sha256sums = de14363e9d4ed92848e524036d9e6b57b2d35cc77d377b7247c38111d2a3defd
diff --git a/PKGBUILD b/PKGBUILD
index 57be6e914467..edd1a2964c99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: judd <jvinet@zeroflux.org>
pkgname=openssh-git
-pkgver=7.1.P1.r189.g5ac712d
+pkgver=7.2.P1.r126.g6310ef2
pkgrel=1
pkgdesc='Free version of the SSH connectivity tools'
url='http://www.openssh.org/portable.html'
@@ -24,24 +24,28 @@ source=('openssh::git://anongit.mindrot.org/openssh.git'
'sshd.conf'
'sshd.pam')
sha256sums=('SKIP'
- 'ff3cbdd0e59ff7dac4dc797d5c0f2b1db4117ddbb49d52f1c4f1771961903878'
+ '4031577db6416fcbaacf8a26a024ecd3939e5c10fe6a86ee3f0eea5093d533b7'
'69cc2abaaae0aa8071b8eac338b2df725f60ce73381843179b74eaac78ba7f1d'
'c5ed9fa629f8f8dbf3bae4edbad4441c36df535088553fe82695c52d7bde30aa'
'de14363e9d4ed92848e524036d9e6b57b2d35cc77d377b7247c38111d2a3defd'
'4effac1186cc62617f44385415103021f72f674f8b8e26447fc1139c670090f6'
'64576021515c0a98b0aaf0a0ae02e0f5ebe8ee525b1e647ab68f369f81ecd846')
-
-backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
-
-install=install
+backup=('etc/ssh/ssh_config'
+ 'etc/ssh/sshd_config'
+ 'etc/pam.d/sshd')
pkgver() {
cd openssh/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
fi
}
diff --git a/install b/install
deleted file mode 100644
index 6f0cd3703fb0..000000000000
--- a/install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_upgrade() {
- if [[ $(vercmp $2 6.2p2) = -1 ]]; then
- cat <<EOF
-
-==> The sshd daemon has been moved to /usr/bin alongside all binaries.
-==> Please update this path in your scripts if applicable.
-
-EOF
- fi
-}
diff --git a/sshdgenkeys.service b/sshdgenkeys.service
index d1e154692c5d..cfb9f6aa17f1 100644
--- a/sshdgenkeys.service
+++ b/sshdgenkeys.service
@@ -6,8 +6,6 @@ ConditionPathExists=|!/etc/ssh/ssh_host_ecdsa_key
ConditionPathExists=|!/etc/ssh/ssh_host_ecdsa_key.pub
ConditionPathExists=|!/etc/ssh/ssh_host_ed25519_key
ConditionPathExists=|!/etc/ssh/ssh_host_ed25519_key.pub
-ConditionPathExists=|!/etc/ssh/ssh_host_key
-ConditionPathExists=|!/etc/ssh/ssh_host_key.pub
ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key
ConditionPathExists=|!/etc/ssh/ssh_host_rsa_key.pub