summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-09-24 09:55:07 +0300
committerChristoph Gysin2017-09-26 21:18:22 +0300
commit18ed63550f3c18cf93d7380771a9db8b39e55fba (patch)
tree3b1b7538e89aef28381c08ec05a29044d4029488
parentf4e5e06c0dea73779c1bd5ab0a6b5a4547804dcd (diff)
downloadaur-18ed63550f3c18cf93d7380771a9db8b39e55fba.tar.gz
fix KeyExchange
See: https://unix.stackexchange.com/questions/316930/archlinux-gssapi-kerberos
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--gssapi-p0.patch4
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9615e73bfd51..8b8d6bf39eba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Sep 24 06:49:11 UTC 2017
+# Sun Sep 24 06:58:39 UTC 2017
pkgbase = openssh-gssapi
pkgdesc = Free version of the SSH connectivity tools
pkgver = 7.1p2
@@ -38,7 +38,7 @@ pkgbase = openssh-gssapi
sha1sums = e12fa910b26a5634e5a6ac39ce1399a132cf6796
sha1sums = c9b2e4ce259cd62ddb00364d3ee6f00a8bf2d05f
sha1sums = d93dca5ebda4610ff7647187f8928a3de28703f3
- sha1sums = 1c2686eca191892a41a899219e1083bc7526967a
+ sha1sums = cf5aa7652259c007d581371007e4d110e486ee29
sha1sums = b11a223eccd8832e75dc69ba5e5b3c5d8606565c
sha1sums = 4ef9b3550107750637d2306777e472167e60653c
diff --git a/PKGBUILD b/PKGBUILD
index 8c1b891fba78..25eddb9b1ad9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,7 @@ sha1sums=('9202f5a2a50c8a55ecfb830609df1e1fde97f758'
'e12fa910b26a5634e5a6ac39ce1399a132cf6796'
'c9b2e4ce259cd62ddb00364d3ee6f00a8bf2d05f'
'd93dca5ebda4610ff7647187f8928a3de28703f3'
- '1c2686eca191892a41a899219e1083bc7526967a'
+ 'cf5aa7652259c007d581371007e4d110e486ee29'
'b11a223eccd8832e75dc69ba5e5b3c5d8606565c'
'4ef9b3550107750637d2306777e472167e60653c')
diff --git a/gssapi-p0.patch b/gssapi-p0.patch
index 33236a6d9c7f..14e473d18b8a 100644
--- a/gssapi-p0.patch
+++ b/gssapi-p0.patch
@@ -16,7 +16,7 @@
+if (options.gss_keyex) {
+ /* Add the GSSAPI mechanisms currently supported on this
+ * client to the key exchange algorithm proposal */
-+ orig = myproposal[PROPOSAL_KEX_ALGS];
++ orig = options.kex_algorithms;
+ if (options.gss_trust_dns)
+ gss_host = (char *)get_canonical_hostname(1);
+ else
@@ -25,7 +25,7 @@
+ gss = ssh_gssapi_client_mechanisms(gss_host, options.gss_client_identity);
+ if (gss) {
+ debug("Offering GSSAPI proposal: %s", gss);
-+ xasprintf(&myproposal[PROPOSAL_KEX_ALGS], "%s,%s", gss, orig);
++ xasprintf(&options.kex_algorithms, "%s,%s", gss, orig);
+ }
+}
+#endif