summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Iooss2016-03-01 18:15:58 +0100
committerNicolas Iooss2016-03-01 18:15:58 +0100
commitce3485bb8b47dd7e8a7edfa400959b3f174eb16a (patch)
treea862ff5d5eafbea65cbe83bb3bb30b257e7df8c3
parentbd19ce0eb32ea1574e3ad721bff7fdd0788d693a (diff)
downloadaur-ce3485bb8b47dd7e8a7edfa400959b3f174eb16a.tar.gz
openssh-selinux 7.2p1-1 update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD6
-rw-r--r--dispatch.patch81
-rw-r--r--error.patch25
-rw-r--r--install10
5 files changed, 9 insertions, 127 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa7f1a19483e..99a5cf4944c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = openssh-selinux
pkgdesc = Free version of the SSH connectivity tools with SELinux support
- pkgver = 7.1p2
+ pkgver = 7.2p1
pkgrel = 1
url = http://www.openssh.org/portable.html
- install = install
arch = i686
arch = x86_64
groups = selinux
@@ -16,22 +15,23 @@ pkgbase = openssh-selinux
depends = libselinux
optdepends = xorg-xauth: X11 forwarding
optdepends = x11-ssh-askpass: input passphrase in X
- provides = openssh=7.1p2-1
- provides = selinux-openssh=7.1p2-1
+ provides = openssh=7.2p1-1
+ provides = selinux-openssh=7.2p1-1
conflicts = openssh
conflicts = selinux-openssh
backup = etc/ssh/ssh_config
backup = etc/ssh/sshd_config
backup = etc/pam.d/sshd
- source = ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-7.1p2.tar.gz
- source = ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-7.1p2.tar.gz.asc
+ source = ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-7.2p1.tar.gz
+ source = ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-7.2p1.tar.gz.asc
source = sshdgenkeys.service
source = sshd@.service
source = sshd.service
source = sshd.socket
source = sshd.conf
source = sshd.pam
- sha1sums = 9202f5a2a50c8a55ecfb830609df1e1fde97f758
+ validpgpkeys = 59C2118ED206D927E667EBE3D3E5F56B6D920D30
+ sha1sums = d30a6fd472199ab5838a7668c0c5fd885fb8d371
sha1sums = SKIP
sha1sums = cc1ceec606c98c7407e7ac21ade23aed81e31405
sha1sums = 6a0ff3305692cf83aca96e10f3bb51e1c26fccda
diff --git a/PKGBUILD b/PKGBUILD
index 79341243e8fc..85b32e8b1ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# SELinux Contributor: Nicky726 <Nicky726@gmail.com>
pkgname=openssh-selinux
-pkgver=7.1p2
+pkgver=7.2p1
pkgrel=1
pkgdesc='Free version of the SSH connectivity tools with SELinux support'
url='http://www.openssh.org/portable.html'
@@ -29,7 +29,7 @@ source=("ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname/-selinux}-
'sshd.socket'
'sshd.conf'
'sshd.pam')
-sha1sums=('9202f5a2a50c8a55ecfb830609df1e1fde97f758' 'SKIP'
+sha1sums=('d30a6fd472199ab5838a7668c0c5fd885fb8d371' 'SKIP'
'cc1ceec606c98c7407e7ac21ade23aed81e31405'
'6a0ff3305692cf83aca96e10f3bb51e1c26fccda'
'ec49c6beba923e201505f5669cea48cad29014db'
@@ -39,8 +39,6 @@ sha1sums=('9202f5a2a50c8a55ecfb830609df1e1fde97f758' 'SKIP'
backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
-install=install
-
build() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
diff --git a/dispatch.patch b/dispatch.patch
deleted file mode 100644
index 9350d8ff6efd..000000000000
--- a/dispatch.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 639d6bc57b1942393ed12fb48f00bc05d4e093e4 Mon Sep 17 00:00:00 2001
-From: djm@openbsd.org <djm@openbsd.org>
-Date: Fri, 01 May 2015 07:10:01 +0000
-Subject: upstream commit
-
-refactor ssh_dispatch_run_fatal() to use sshpkt_fatal()
- to better report error conditions. Teach sshpkt_fatal() about ECONNRESET.
-
-Improves error messages on TCP connection resets. bz#2257
-
-ok dtucker@
----
-diff --git a/dispatch.c b/dispatch.c
-index afe6182..aac933e 100644
---- a/dispatch.c
-+++ b/dispatch.c
-@@ -1,4 +1,4 @@
--/* $OpenBSD: dispatch.c,v 1.26 2015/02/12 20:34:19 dtucker Exp $ */
-+/* $OpenBSD: dispatch.c,v 1.27 2015/05/01 07:10:01 djm Exp $ */
- /*
- * Copyright (c) 2000 Markus Friedl. All rights reserved.
- *
-@@ -137,22 +137,6 @@ ssh_dispatch_run_fatal(struct ssh *ssh, int mode, volatile sig_atomic_t *done,
- {
- int r;
-
-- if ((r = ssh_dispatch_run(ssh, mode, done, ctxt)) != 0) {
-- switch (r) {
-- case SSH_ERR_CONN_CLOSED:
-- logit("Connection closed by %.200s",
-- ssh_remote_ipaddr(ssh));
-- cleanup_exit(255);
-- case SSH_ERR_CONN_TIMEOUT:
-- logit("Connection to %.200s timed out while "
-- "waiting to read", ssh_remote_ipaddr(ssh));
-- cleanup_exit(255);
-- case SSH_ERR_DISCONNECTED:
-- logit("Disconnected from %.200s",
-- ssh_remote_ipaddr(ssh));
-- cleanup_exit(255);
-- default:
-- fatal("%s: %s", __func__, ssh_err(r));
-- }
-- }
-+ if ((r = ssh_dispatch_run(ssh, mode, done, ctxt)) != 0)
-+ sshpkt_fatal(ssh, __func__, r);
- }
-diff --git a/packet.c b/packet.c
-index 4922573..a7727ef 100644
---- a/packet.c
-+++ b/packet.c
-@@ -1,4 +1,4 @@
--/* $OpenBSD: packet.c,v 1.208 2015/02/13 18:57:00 markus Exp $ */
-+/* $OpenBSD: packet.c,v 1.212 2015/05/01 07:10:01 djm Exp $ */
- /*
- * Author: Tatu Ylonen <ylo@cs.hut.fi>
- * Copyright (c) 1995 Tatu Ylonen <ylo@cs.hut.fi>, Espoo, Finland
-@@ -1920,9 +1920,19 @@ sshpkt_fatal(struct ssh *ssh, const char *tag, int r)
- logit("Connection closed by %.200s", ssh_remote_ipaddr(ssh));
- cleanup_exit(255);
- case SSH_ERR_CONN_TIMEOUT:
-- logit("Connection to %.200s timed out while "
-- "waiting to write", ssh_remote_ipaddr(ssh));
-+ logit("Connection to %.200s timed out", ssh_remote_ipaddr(ssh));
- cleanup_exit(255);
-+ case SSH_ERR_DISCONNECTED:
-+ logit("Disconnected from %.200s",
-+ ssh_remote_ipaddr(ssh));
-+ cleanup_exit(255);
-+ case SSH_ERR_SYSTEM_ERROR:
-+ if (errno == ECONNRESET) {
-+ logit("Connection reset by %.200s",
-+ ssh_remote_ipaddr(ssh));
-+ cleanup_exit(255);
-+ }
-+ /* FALLTHROUGH */
- default:
- fatal("%s%sConnection to %.200s: %s",
- tag != NULL ? tag : "", tag != NULL ? ": " : "",
---
-cgit v0.9.2
diff --git a/error.patch b/error.patch
deleted file mode 100644
index 1616ba3630ef..000000000000
--- a/error.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 4d24b3b6a4a6383e05e7da26d183b79fa8663697 Mon Sep 17 00:00:00 2001
-From: Damien Miller <djm@mindrot.org>
-Date: Thu, 19 Mar 2015 22:11:59 +0000
-Subject: remove error() accidentally inserted for debugging
-
-pointed out by Christian Hesse
----
-diff --git a/monitor_wrap.c b/monitor_wrap.c
-index b379f05..d39d491 100644
---- a/monitor_wrap.c
-+++ b/monitor_wrap.c
-@@ -153,10 +153,8 @@ mm_request_receive(int sock, Buffer *m)
- debug3("%s entering", __func__);
-
- if (atomicio(read, sock, buf, sizeof(buf)) != sizeof(buf)) {
-- if (errno == EPIPE) {
-- error("%s: socket closed", __func__);
-+ if (errno == EPIPE)
- cleanup_exit(255);
-- }
- fatal("%s: read: %s", __func__, strerror(errno));
- }
- msg_len = get_u32(buf);
---
-cgit v0.9.2
diff --git a/install b/install
deleted file mode 100644
index 6f0cd3703fb0..000000000000
--- a/install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_upgrade() {
- if [[ $(vercmp $2 6.2p2) = -1 ]]; then
- cat <<EOF
-
-==> The sshd daemon has been moved to /usr/bin alongside all binaries.
-==> Please update this path in your scripts if applicable.
-
-EOF
- fi
-}