summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlily wilson2015-12-13 07:58:45 -0500
committerlily wilson2015-12-13 07:58:45 -0500
commit70d7ba7e5ab152c5cc5180d201752ab9a1193693 (patch)
treecc817f0604cf99b1f1d1332b08301afd318b0919
downloadaur-70d7ba7e5ab152c5cc5180d201752ab9a1193693.tar.gz
initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD76
-rw-r--r--ca-dir.patch22
-rw-r--r--no-rpath.patch11
4 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdc2114a6d5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sun Dec 13 12:45:03 UTC 2015
+pkgbase = openssl-pre
+ pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security, including alpha and beta versions
+ pkgver = 1.1.0.pre1
+ pkgrel = 1
+ url = https://www.openssl.org
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ depends = zlib
+ depends = perl
+ depends = openssl102
+ optdepends = ca-certificates
+ options = !makeflags
+ backup = etc/ssl/openssl.cnf
+ source = https://www.openssl.org/source/openssl-1.1.0-pre1.tar.gz
+ source = https://www.openssl.org/source/openssl-1.1.0-pre1.tar.gz.asc
+ source = no-rpath.patch
+ source = ca-dir.patch
+ md5sums = 51f5fafe30a430f62ed66a45ca431274
+ md5sums = SKIP
+ md5sums = dc78d3d06baffc16217519242ce92478
+ md5sums = 381ecca640ea989c8deb57e8a2505c8c
+
+pkgname = openssl-pre
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5697865f3a80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: lily wilson <lily@lily.ml>
+
+_pkgname=openssl
+pkgname=$_pkgname-pre
+_ver=1.1.0-pre1
+# use a pacman compatible version scheme
+pkgver=${_ver/-/.}
+#pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
+#pkgver=$_ver
+pkgrel=1
+pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security, including alpha and beta versions'
+arch=('i686' 'x86_64')
+url='https://www.openssl.org'
+license=('custom:BSD')
+depends=('zlib' 'perl' 'openssl102')
+optdepends=('ca-certificates')
+options=('!makeflags')
+backup=('etc/ssl/openssl.cnf')
+source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
+ "https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz.asc"
+ 'no-rpath.patch'
+ 'ca-dir.patch')
+md5sums=('51f5fafe30a430f62ed66a45ca431274'
+ 'SKIP'
+ 'dc78d3d06baffc16217519242ce92478'
+ '381ecca640ea989c8deb57e8a2505c8c')
+validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
+
+prepare() {
+ cd $srcdir/$_pkgname-$_ver
+
+ # remove rpath: http://bugs.archlinux.org/task/14367
+ patch -p0 -i $srcdir/no-rpath.patch
+ # set ca dir to /etc/ssl by default
+ patch -p0 -i $srcdir/ca-dir.patch
+}
+
+build() {
+ cd $srcdir/$_pkgname-$_ver
+
+ if [ "${CARCH}" == 'x86_64' ]; then
+ openssltarget='linux-x86_64'
+ optflags='enable-ec_nistp_64_gcc_128'
+ elif [ "${CARCH}" == 'i686' ]; then
+ openssltarget='linux-elf'
+ optflags=''
+ fi
+
+ # mark stack as non-executable: http://bugs.archlinux.org/task/12434
+ ./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
+ shared zlib ${optflags} \
+ "${openssltarget}" \
+ "-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
+
+ make depend
+ make
+}
+
+check() {
+ cd $srcdir/$_pkgname-$_ver
+
+ # make test now fails because CA.sh is gone and the patch
+ # changes CA.pl.in, but not CA.pl. Will try to fix later.
+
+ # the test fails due to missing write permissions in /etc/ssl
+ # revert this patch for make test
+ #patch -p0 -R -i $srcdir/ca-dir.patch
+ #make test
+ #patch -p0 -i $srcdir/ca-dir.patch
+}
+
+package() {
+ cd $srcdir/$_pkgname-$_ver
+ make INSTALL_PREFIX=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install
+ install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/ca-dir.patch b/ca-dir.patch
new file mode 100644
index 000000000000..1ad68f259dac
--- /dev/null
+++ b/ca-dir.patch
@@ -0,0 +1,22 @@
+--- apps/CA.pl.in 2006-04-28 02:30:49.000000000 +0200
++++ apps/CA.pl.in 2010-04-01 00:35:02.600553509 +0200
+@@ -28,7 +28,7 @@
+ my $PKCS12 = "$openssl pkcs12";
+
+ # default openssl.cnf file has setup as per the following
+-my $CATOP = "./demoCA";
++my $CATOP = "/etc/ssl";
+ my $CAKEY = "cakey.pem";
+ my $CAREQ = "careq.pem";
+ my $CACERT = "cacert.pem";
+--- apps/openssl.cnf 2009-04-04 20:09:43.000000000 +0200
++++ apps/openssl.cnf 2010-04-01 00:35:02.607220681 +0200
+@@ -39,7 +39,7 @@
+ ####################################################################
+ [ CA_default ]
+
+-dir = ./demoCA # Where everything is kept
++dir = /etc/ssl # Where everything is kept
+ certs = $dir/certs # Where the issued certs are kept
+ crl_dir = $dir/crl # Where the issued crl are kept
+ database = $dir/index.txt # database index file.
diff --git a/no-rpath.patch b/no-rpath.patch
new file mode 100644
index 000000000000..ebd95e23d397
--- /dev/null
+++ b/no-rpath.patch
@@ -0,0 +1,11 @@
+--- Makefile.shared.no-rpath 2005-06-23 22:47:54.000000000 +0200
++++ Makefile.shared 2005-11-16 22:35:37.000000000 +0100
+@@ -153,7 +153,7 @@
+ NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
+
+-DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
++DO_GNU_APP=LDFLAGS="$(CFLAGS)"
+
+ #This is rather special. It's a special target with which one can link
+ #applications without bothering with any features that have anything to