summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-08 22:38:17 +0100
committerFelix Golatofski2020-01-08 22:38:17 +0100
commit8814226eabb3c34a451dcf76d2261b44f3bf8773 (patch)
tree71a83d08721f948109cf02be63045359cd6d83e1
parentc9e2e183b2eac07633531660dea0bfd527b27c54 (diff)
downloadaur-8814226eabb3c34a451dcf76d2261b44f3bf8773.tar.gz
Updated to 1.1.1d
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--no-rpath.patch11
-rw-r--r--ssl3-test-failure.patch26
4 files changed, 20 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbe32a0750ee..9ad9460080a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openssl-static
pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (static library)
- pkgver = 1.0.2.h
+ pkgver = 1.1.1.d
pkgrel = 1
url = https://www.openssl.org
arch = i686
@@ -8,19 +8,15 @@ pkgbase = openssl-static
license = custom:BSD
depends = perl
optdepends = openssl: headers and pkg-config files
- options = !makeflags
options = staticlibs
- source = https://www.openssl.org/source/openssl-1.0.2h.tar.gz
- source = https://www.openssl.org/source/openssl-1.0.2h.tar.gz.asc
- source = no-rpath.patch
- source = ssl3-test-failure.patch
+ source = https://www.openssl.org/source/openssl-1.1.1d.tar.gz
+ source = https://www.openssl.org/source/openssl-1.1.1d.tar.gz.asc
source = ca-dir.patch
validpgpkeys = 8657ABB260F056B1E5190839D9C4D26D0E604491
- md5sums = 9392e65072ce4b614c1392eefc1f23d0
- md5sums = SKIP
- md5sums = dc78d3d06baffc16217519242ce92478
- md5sums = 62fc492252edd3283871632bb77fadbe
- md5sums = 3bf51be3a1bbd262be46dc619f92aa90
+ validpgpkeys = 7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C
+ sha512sums = 2bc9f528c27fe644308eb7603c992bac8740e9f0c3601a130af30c9ffebbf7e0f5c28b76a00bbb478bad40fbe89b4223a58d604001e1713da71ff4b7fe6a08a7
+ sha512sums = SKIP
+ sha512sums = 209ad95ba6757cc17a3550dbe1e231e4dc9a77516f69478c5970722d32157ee53b68cd614650eae6cd8c1c3961eb0de3a2e6ee00f973bf16b537c608fce1936d
pkgname = openssl-static
diff --git a/PKGBUILD b/PKGBUILD
index 35438762066b..c02f27105f52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,10 @@
-# $Id$
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-pkgname=openssl-static
_pkgname=openssl
-_ver=1.0.2h
+pkgname=$_pkgname-static
+_ver=1.1.1d
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
-#pkgver=$_ver
pkgrel=1
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (static library)'
arch=('i686' 'x86_64')
@@ -14,29 +12,18 @@ url='https://www.openssl.org'
license=('custom:BSD')
depends=('perl')
optdepends=('openssl: headers and pkg-config files')
-options=('!makeflags' 'staticlibs')
-#backup=('etc/ssl/openssl.cnf')
-source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"
- "https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz.asc"
- 'no-rpath.patch'
- 'ssl3-test-failure.patch'
+options=('staticlibs')
+source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
-md5sums=('9392e65072ce4b614c1392eefc1f23d0'
- 'SKIP'
- 'dc78d3d06baffc16217519242ce92478'
- '62fc492252edd3283871632bb77fadbe'
- '3bf51be3a1bbd262be46dc619f92aa90')
-validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491')
+sha512sums=('2bc9f528c27fe644308eb7603c992bac8740e9f0c3601a130af30c9ffebbf7e0f5c28b76a00bbb478bad40fbe89b4223a58d604001e1713da71ff4b7fe6a08a7'
+ 'SKIP'
+ '209ad95ba6757cc17a3550dbe1e231e4dc9a77516f69478c5970722d32157ee53b68cd614650eae6cd8c1c3961eb0de3a2e6ee00f973bf16b537c608fce1936d')
+validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
+ '7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
prepare() {
cd $srcdir/$_pkgname-$_ver
- # remove rpath: http://bugs.archlinux.org/task/14367
- patch -p0 -i $srcdir/no-rpath.patch
-
- # disable a test that fails when ssl3 is disabled
- patch -p1 -i $srcdir/ssl3-test-failure.patch
-
# set ca dir to /etc/ssl by default
patch -p0 -i $srcdir/ca-dir.patch
}
@@ -58,8 +45,8 @@ build() {
"${openssltarget}" \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
- make depend -j
- make -j
+ make depend
+ make
}
check() {
@@ -67,13 +54,13 @@ check() {
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
patch -p0 -R -i $srcdir/ca-dir.patch
- #make test
+ make test
patch -p0 -i $srcdir/ca-dir.patch
}
package() {
cd $srcdir/$_pkgname-$_ver
- make INSTALL_PREFIX=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install
+ make INSTALL_PREFIX=$pkgdir MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
rm -rf "$pkgdir/usr/"{bin,include,share,lib/engines,lib/pkgconfig} $pkgdir/usr/lib/*.so* $pkgdir/etc
install -D -m644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/no-rpath.patch b/no-rpath.patch
deleted file mode 100644
index ebd95e23d397..000000000000
--- a/no-rpath.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.shared.no-rpath 2005-06-23 22:47:54.000000000 +0200
-+++ Makefile.shared 2005-11-16 22:35:37.000000000 +0100
-@@ -153,7 +153,7 @@
- NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
- SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
-
--DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
-+DO_GNU_APP=LDFLAGS="$(CFLAGS)"
-
- #This is rather special. It's a special target with which one can link
- #applications without bothering with any features that have anything to
diff --git a/ssl3-test-failure.patch b/ssl3-test-failure.patch
deleted file mode 100644
index d161c3d4a593..000000000000
--- a/ssl3-test-failure.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Kurt Roeckx <kurt@roeckx.be>
-Date: Sun, 6 Sep 2015 16:04:11 +0200
-Subject: Disable SSLv3 test in test suite
-
-When testing SSLv3 the test program returns 0 for skip. The test for weak DH
-expects a failure, but gets success.
-
-It should probably be changed to return something other than 0 for a skipped
-test.
----
- test/testssl | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/testssl b/test/testssl
-index 747e4ba..1e4370b 100644
---- a/test/testssl
-+++ b/test/testssl
-@@ -160,7 +160,7 @@ test_cipher() {
- }
-
- echo "Testing ciphersuites"
--for protocol in TLSv1.2 SSLv3; do
-+for protocol in TLSv1.2; do
- echo "Testing ciphersuites for $protocol"
- for cipher in `../util/shlib_wrap.sh ../apps/openssl ciphers "RSA+$protocol" | tr ':' ' '`; do
- test_cipher $cipher $protocol