summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Falkenberg2022-11-24 05:51:40 +0100
committerRobert Falkenberg2022-11-24 05:51:40 +0100
commitaeaf64df85dd240597cecac1967bc56445a89fe6 (patch)
tree3eb04f9169df9b9f663e7ebeb9f0da8aa7b18fb4
parentf7903cb57614f0486a57454603728eef7c07ee1e (diff)
downloadaur-aeaf64df85dd240597cecac1967bc56445a89fe6.tar.gz
upgpkg: openssl 3.0.7-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--ca-dir.patch16
3 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f76a89cf6c..67fbc64d7866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,30 @@
pkgbase = openssl-static
pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (with static libs)
- pkgver = 1.1.1.q
+ pkgver = 3.0.7
pkgrel = 1
url = https://www.openssl.org
arch = x86_64
- license = custom:BSD
+ license = Apache
makedepends = perl
depends = glibc
optdepends = ca-certificates
optdepends = perl
- provides = openssl=1.1.1.q
+ provides = libcrypto.so
+ provides = libssl.so
+ provides = openssl=3.0.7
conflicts = openssl
replaces = openssl-perl
replaces = openssl-doc
options = staticlibs
backup = etc/ssl/openssl.cnf
- source = https://www.openssl.org/source/openssl-1.1.1q.tar.gz
- source = https://www.openssl.org/source/openssl-1.1.1q.tar.gz.asc
+ source = https://www.openssl.org/source/openssl-3.0.7.tar.gz
+ source = https://www.openssl.org/source/openssl-3.0.7.tar.gz.asc
source = ca-dir.patch
validpgpkeys = 8657ABB260F056B1E5190839D9C4D26D0E604491
validpgpkeys = 7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C
- sha256sums = d7939ce614029cdff0b6c20f0e2e5703158a489a72b2507b8bd51bf8c8fd10ca
+ validpgpkeys = A21FAB74B0088AA361152586B8EF1A6BA9DA2D5C
+ sha256sums = 83049d042a260e696f62406ac5c08bf706fd84383f945cf21bd61e9ed95c396e
sha256sums = SKIP
- sha256sums = 75aa8c2c638c8a3ebfd9fa146fc61c7ff878fc997dc6aa10d39e4b2415d669b2
+ sha256sums = 0a32d9ca68e8d985ce0bfef6a4c20b46675e06178cc2d0bf6d91bd6865d648b7
pkgname = openssl-static
diff --git a/PKGBUILD b/PKGBUILD
index e9abf286a037..ab5b53db6f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,38 @@
# Maintainer: Robert Falkenberg <robert.falkenberg@srs.io>
-# Contributor: chn <g897331845@gmail.com>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=openssl-static
_pkgname=openssl
-_ver=1.1.1q
+_ver=3.0.7
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
pkgrel=1
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (with static libs)'
arch=('x86_64')
url='https://www.openssl.org'
-license=('custom:BSD')
+license=('Apache')
depends=('glibc')
makedepends=('perl')
optdepends=('ca-certificates' 'perl')
replaces=('openssl-perl' 'openssl-doc')
+provides=('libcrypto.so' 'libssl.so' "openssl=$pkgver")
backup=('etc/ssl/openssl.cnf')
options=('staticlibs')
-provides=("openssl=$pkgver")
conflicts=('openssl')
source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
'ca-dir.patch')
-sha256sums=('d7939ce614029cdff0b6c20f0e2e5703158a489a72b2507b8bd51bf8c8fd10ca'
+sha256sums=('83049d042a260e696f62406ac5c08bf706fd84383f945cf21bd61e9ed95c396e'
'SKIP'
- '75aa8c2c638c8a3ebfd9fa146fc61c7ff878fc997dc6aa10d39e4b2415d669b2')
+ '0a32d9ca68e8d985ce0bfef6a4c20b46675e06178cc2d0bf6d91bd6865d648b7')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
- '7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
+ '7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C'
+ 'A21FAB74B0088AA361152586B8EF1A6BA9DA2D5C')
prepare() {
cd "$srcdir/$_pkgname-$_ver"
# set ca dir to /etc/ssl by default
- patch -p0 -i "$srcdir/ca-dir.patch"
+ patch -Np1 -i "$srcdir/ca-dir.patch"
}
build() {
@@ -41,7 +41,7 @@ build() {
export CFLAGS="-fPIC ${CFLAGS}"
# mark stack as non-executable: http://bugs.archlinux.org/task/12434
./Configure --prefix=/usr --openssldir=/etc/ssl --libdir=lib \
- shared no-ssl3-method enable-ec_nistp_64_gcc_128 linux-x86_64 \
+ shared enable-ktls enable-ec_nistp_64_gcc_128 linux-x86_64 \
"-Wa,--noexecstack ${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
make depend
@@ -53,12 +53,12 @@ check() {
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
- patch -p0 -R -i "$srcdir/ca-dir.patch"
+ patch -Rp1 -i "$srcdir/ca-dir.patch"
- make test
+ make HARNESS_JOBS=$(nproc) test
- patch -p0 -i "$srcdir/ca-dir.patch"
- # re-run make to re-generate CA.pl from th patched .in file.
+ patch -Np1 -i "$srcdir/ca-dir.patch"
+ # re-run make to re-generate CA.pl from the patched .in file.
make apps/CA.pl
}
@@ -67,5 +67,5 @@ package() {
make DESTDIR="$pkgdir" MANDIR=/usr/share/man MANSUFFIX=ssl install_sw install_ssldirs install_man_docs
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
diff --git a/ca-dir.patch b/ca-dir.patch
index d0ad70470aa9..ba05eaed0456 100644
--- a/ca-dir.patch
+++ b/ca-dir.patch
@@ -1,17 +1,17 @@
---- apps/CA.pl.in 2019-09-10 15:13:07.000000000 +0200
-+++ apps/CA.pl.in 2019-10-06 09:34:23.960864556 +0200
-@@ -33,7 +33,7 @@
+--- a/apps/CA.pl.in
++++ b/apps/CA.pl.in
+@@ -29,7 +29,7 @@
my $PKCS12 = "$openssl pkcs12";
- # default openssl.cnf file has setup as per the following
+ # Default values for various configuration settings.
-my $CATOP = "./demoCA";
+my $CATOP = "/etc/ssl";
my $CAKEY = "cakey.pem";
my $CAREQ = "careq.pem";
my $CACERT = "cacert.pem";
---- apps/openssl.cnf 2019-09-10 15:13:07.000000000 +0200
-+++ apps/openssl.cnf 2019-10-06 09:34:23.960864556 +0200
-@@ -42,7 +42,7 @@
+--- a/apps/openssl.cnf
++++ b/apps/openssl.cnf
+@@ -79,7 +79,7 @@
####################################################################
[ CA_default ]
@@ -20,7 +20,7 @@
certs = $dir/certs # Where the issued certs are kept
crl_dir = $dir/crl # Where the issued crl are kept
database = $dir/index.txt # database index file.
-@@ -325,7 +325,7 @@
+@@ -309,7 +309,7 @@
[ tsa_config1 ]
# These are used by the TSA reply generation only.