summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBigfootACA2021-04-08 21:36:37 +0800
committerBigfootACA2021-04-08 21:36:37 +0800
commite6a5f14f4f62dce12fe01cc67808c0992c219e9c (patch)
treec66992267576f53ad678cf9fbaf7c4b637963e00
parentdd33d749cb39f9e7203b5945c0d856861caf4bac (diff)
downloadaur-e6a5f14f4f62dce12fe01cc67808c0992c219e9c.tar.gz
add missing documents
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ecb87a5b6311..94a762a10810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -148,7 +148,7 @@ prepare(){
build(){
cd $_pyname-$pkgver
python setup.py build
- #sphinx-build -b html doc/source doc/build/html
+ sphinx-build -b html doc/source doc/build/html
}
#check(){
@@ -183,11 +183,13 @@ _package_pkg(){
}
_package_doc(){
- pkgdesc="OpenStack Image Service Documents"
+ pkgdesc="${pkgdesc} Documents"
depends=()
cd $_pyname-$pkgver
- mkdir -p "${pkgdir}/usr/share/doc"
- #cp -r doc/build/html "${pkgdir}/usr/share/doc/${pkgname}"
+ DOCDIR=$pkgdir/usr/share/doc
+ mkdir -p "$DOCDIR"
+ cp -r doc/build/html "$DOCDIR/$pkgbase"
+ rm -r "$DOCDIR/$pkgbase/.doctrees"
}
eval "package_${pkgbase}(){ _package_pkg; }"