summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill R2017-08-03 00:46:24 -0500
committerWill R2017-08-03 00:46:24 -0500
commit385736ecacf0fba1bb16ffb66b9fe257178bb6ae (patch)
tree37ec696c7ab953aee981a7aae62e696d1f2c3498
downloadaur-385736ecacf0fba1bb16ffb66b9fe257178bb6ae.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--openstopmotion.install23
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c7c3fcff3ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = openstopmotion
+ pkgdesc = OpenStopMotion Animation Capture
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = https://www.pfp.de/osm/
+ install = openstopmotion.install
+ arch = x86_64
+ license = GPL
+ makedepends = pacman>=4.2.0
+ depends = pcre
+ depends = libtiff
+ provides = openstopmotion=0.6.3
+ source = https://downloads.sourceforge.net/project/openstopmotion/Ubuntu%2012.04/OpenStopMotion-0.6.3-Ubuntu-12.04-amd64.deb
+ sha256sums = bfc614f76fede8ee4074b738682db4a22cf8754979f72baea2609cdd175dea37
+
+pkgname = openstopmotion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9714036d5a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Will R (will at digi-merc dot org)
+# Contributors:
+
+pkgname=openstopmotion
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="OpenStopMotion Animation Capture"
+arch=('x86_64')
+url="https://www.pfp.de/osm/"
+license=('GPL')
+depends=('pcre' 'libtiff')
+makedepends=('pacman>=4.2.0')
+provides=("openstopmotion=$pkgver")
+install="$pkgname.install"
+source=("https://downloads.sourceforge.net/project/openstopmotion/Ubuntu%2012.04/OpenStopMotion-0.6.3-Ubuntu-12.04-amd64.deb")
+sha256sums=('bfc614f76fede8ee4074b738682db4a22cf8754979f72baea2609cdd175dea37')
+
+package() {
+ bsdtar -xzf data.tar.gz -C "$pkgdir/"
+ chmod -R 755 "$pkgdir/"
+}
+# vim:set ts=2 sw=2 et:
diff --git a/openstopmotion.install b/openstopmotion.install
new file mode 100644
index 000000000000..e8f293581c09
--- /dev/null
+++ b/openstopmotion.install
@@ -0,0 +1,23 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Creating library symlinks"
+ ln -s /usr/lib/libtiff.so /usr/lib/libtiff.so.4
+ ln -s /usr/lib/libpcre.so /usr/lib/libpcre.so.3
+}
+
+post_upgrade() {
+ post_install
+}