summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2020-12-29 12:31:34 +0100
committerAlphaJack2020-12-29 12:31:34 +0100
commit5cb28889aab6ee7c8828063e5a32ee9751df720b (patch)
tree8bbe12590a3b79882f07a969205fdd2e97d3a409
parent632828b246149346fa1cd51e70e09b0932c24bdc (diff)
downloadaur-5cb28889aab6ee7c8828063e5a32ee9751df720b.tar.gz
Updated package
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD50
2 files changed, 34 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3401c357b3c1..c1e87b1d67d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = opentimestamps-client-git
pkgdesc = Command-line tool to create and validate timestamp proofs with the OpenTimestamps protocol
- pkgver = 0.3.1.r10.g10677dfe
+ pkgver = 0.7.0.r2.g40de42f
pkgrel = 1
url = https://github.com/opentimestamps/opentimestamps-client
arch = any
license = LGPL3
- depends = python-opentimestamps-git
- optdepends = python-pysocks: for socks5 support
+ checkdepends = python-gitpython
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-opentimestamps
+ provides = opentimestamps-client
source = git+https://github.com/opentimestamps/opentimestamps-client
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = opentimestamps-client-git
diff --git a/PKGBUILD b/PKGBUILD
index edcb492a8f1e..53cde5e0cb20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,36 @@
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Maintainer: AlphaJack <alpha at tuta dot io>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
-pkgname=opentimestamps-client-git
-pkgver=0.3.1.r10.g10677dfe
+pkgname="opentimestamps-client-git"
+pkgver=0.7.0.r2.g40de42f
pkgrel=1
pkgdesc="Command-line tool to create and validate timestamp proofs with the OpenTimestamps protocol"
-arch=(any)
+license=("LGPL3")
+arch=("any")
+provides=("opentimestamps-client")
url="https://github.com/opentimestamps/opentimestamps-client"
-license=('LGPL3')
-depends=('python-opentimestamps-git')
-optdepends=('python-pysocks: for socks5 support')
-source=(git+https://github.com/opentimestamps/opentimestamps-client)
-md5sums=('SKIP')
-_python_site=$(python -c 'import site; print(site.getsitepackages()[0]);')
+depends=("python-opentimestamps")
+makedepends=("git" "python-setuptools")
+checkdepends=("python-gitpython")
+source=("git+$url")
+sha256sums=("SKIP")
-pkgver() {
- cd ${pkgbase%-git}
- git describe --long --tags | sed 's/^opentimestamps-client-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+pkgver(){
+ cd "opentimestamps-client"
+ git describe --long --tags | sed 's/^opentimestamps-client-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd ${pkgbase%-git}
- install -dm755 "${pkgdir}/${_python_site}" "${pkgdir}/usr/share/$pkgname"
- cp -a otsclient "${pkgdir}/${_python_site}"
- python -m compileall "${pkgdir}/${_python_site}/otsclient"
- python -O -m compileall "${pkgdir}/${_python_site}/otsclient"
+build(){
+ cd "opentimestamps-client"
+ python setup.py build
+}
+
+check(){
+ cd "opentimestamps-client"
+ python -m unittest discover -v
+}
- install -Dm755 ots "$pkgdir/usr/bin/ots"
- install -Dm755 ots-git-gpg-wrapper "$pkgdir/usr/share/$pkgname/ots-git-gpg-wrapper"
- printf '%s\n' "#!/bin/sh" "/usr/share/$pkgname/ots-git-gpg-wrapper --gpg-program /usr/bin/gpg \`git config gpg.ots-args\` -- \"\$@\"" > "$pkgdir/usr/bin/ots-git-gpg-wrapper.sh"
- chmod 755 "$pkgdir/usr/bin/ots-git-gpg-wrapper.sh"
+package(){
+ cd "opentimestamps-client"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
}