summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Redaelli2016-10-09 14:32:33 +0200
committerTimothy Redaelli2016-10-09 15:05:26 +0200
commite601e8bbdea846cce0d7beeca5f96a84f32351dd (patch)
tree14d6b4cb0f5b9b9a842e4c406f1b891fb4701269
downloadaur-e601e8bbdea846cce0d7beeca5f96a84f32351dd.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6bc7a84dafb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = opentimestamps-client-git
+ pkgdesc = Command-line tool to create and validate timestamp proofs with the OpenTimestamps protocol
+ pkgver = 0.2.2.r18.gb085f8f
+ pkgrel = 1
+ url = https://github.com/opentimestamps/opentimestamps-client
+ arch = any
+ license = LGPL3
+ depends = python-opentimestamps-git
+ source = git+https://github.com/opentimestamps/opentimestamps-client
+ md5sums = SKIP
+
+pkgname = opentimestamps-client-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6957b00f5201
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+
+pkgname=opentimestamps-client-git
+pkgver=0.2.2.r18.gb085f8f
+pkgrel=1
+pkgdesc="Command-line tool to create and validate timestamp proofs with the OpenTimestamps protocol"
+arch=(any)
+url="https://github.com/opentimestamps/opentimestamps-client"
+license=('LGPL3')
+depends=('python-opentimestamps-git')
+source=(git+https://github.com/opentimestamps/opentimestamps-client)
+md5sums=('SKIP')
+_python_site=$(python -c 'import site; print(site.getsitepackages()[0]);')
+
+pkgver() {
+ cd ${pkgbase%-git}
+ git describe --long --tags | sed 's/^opentimestamps-client-v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd ${pkgbase%-git}
+ install -dm755 "${pkgdir}/${_python_site}" "${pkgdir}/usr/share/$pkgname"
+ cp -a otsclient "${pkgdir}/${_python_site}"
+ python -m compileall "${pkgdir}/${_python_site}/otsclient"
+ python -O -m compileall "${pkgdir}/${_python_site}/otsclient"
+
+ install -Dm755 ots "$pkgdir/usr/bin/ots"
+ install -Dm755 git-gpg-wrapper "$pkgdir/usr/share/$pkgname/ots-git-gpg-wrapper"
+ printf '%s\n' "#!/bin/sh" "/usr/share/$pkgname/ots-git-gpg-wrapper --gpg-program /usr/bin/gpg -- \"\$@\"" > "$pkgdir/usr/bin/ots-git-gpg-wrapper.sh"
+ chmod 755 "$pkgdir/usr/bin/ots-git-gpg-wrapper.sh"
+}