summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLW-archlinux2019-11-21 13:30:26 +0100
committerLW-archlinux2019-11-21 13:30:26 +0100
commit559b9dc9c57e02d41eaf720f06a4bba23c4002e3 (patch)
tree2e24016cd9dce17f46c4b3972558c3774517e3ff
parentd815f06915cf3b0070f38c498e8a37ce2d779147 (diff)
downloadaur-559b9dc9c57e02d41eaf720f06a4bba23c4002e3.tar.gz
updated to 0.2, do not autoactivate services (removed install file) also removed not-needed patch
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD25
-rw-r--r--opentmpfiles.install15
-rw-r--r--replace-sbin-with-usr-bin.patch18
4 files changed, 14 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fc29018dc6f..1e3778ea45c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = opentmpfiles
- pkgdesc = a standalone utility for handling systemd-style tmpfiles.d settings
- pkgver = 0.1.3
+ pkgdesc = Utility for handling systemd-style tmpfiles.d settings for systems booting openrc
+ pkgver = 0.2
pkgrel = 1
url = https://github.com/openrc/opentmpfiles
- install = opentmpfiles.install
arch = any
license = BSD
depends = openrc
depends = sh
backup = etc/openrc/conf.d/opentmpfiles-dev
backup = etc/openrc/conf.d/opentmpfiles-setup
- source = opentmpfiles-0.1.3::https://github.com/OpenRC/opentmpfiles/archive/0.1.3.tar.gz
- source = replace-sbin-with-usr-bin.patch
- sha512sums = fd0b10ebfeb621466edadede50ec6e8f415861ab3b14b833c75bd71f7296e9c091e59144d39e1f9efd342b6d97776cade5a692c941085e33e9651fd885da7121
- sha512sums = 7ff8e3269668850f0d812bb6003ec5111ee89a5beab882fd09c9a2cbb30b35a0b96c083bde007845418e8747082160f907b5043562425d909a13af0beacdb1e6
+ source = opentmpfiles-0.2::https://github.com/OpenRC/opentmpfiles/archive/0.2.tar.gz
+ md5sums = 5197fcae0f2fb2ed223e92dae96497cc
+ sha512sums = bc384cc9156ba6c54d3308ddad4d26b1877f020aa8558e82df2ed49ffa65e0fed5a49eaa11b27193bfe2ad11a4d7368f7cdbc225b820b309af3b299327ddb07b
pkgname = opentmpfiles
diff --git a/PKGBUILD b/PKGBUILD
index cfb7edfc0b30..67b1c5ee4b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
# Maintainer Lone_Wolf <lonewolf at xs4all dot nl>
-
pkgname=opentmpfiles
-pkgver=0.1.3
+pkgver=0.2
pkgrel=1
-pkgdesc='a standalone utility for handling systemd-style tmpfiles.d settings'
+pkgdesc='Utility for handling systemd-style tmpfiles.d settings for systems booting openrc'
arch=('any')
url='https://github.com/openrc/opentmpfiles'
license=('BSD')
@@ -12,18 +11,12 @@ depends=('openrc' 'sh')
backup=(etc/openrc/conf.d/opentmpfiles-dev etc/openrc/conf.d/opentmpfiles-setup )
-source=($pkgname-$pkgver::https://github.com/OpenRC/$pkgname/archive/$pkgver.tar.gz
- replace-sbin-with-usr-bin.patch
- )
-install=$pkgname.install
+source=($pkgname-$pkgver::https://github.com/OpenRC/$pkgname/archive/$pkgver.tar.gz)
-sha512sums=('fd0b10ebfeb621466edadede50ec6e8f415861ab3b14b833c75bd71f7296e9c091e59144d39e1f9efd342b6d97776cade5a692c941085e33e9651fd885da7121'
- '7ff8e3269668850f0d812bb6003ec5111ee89a5beab882fd09c9a2cbb30b35a0b96c083bde007845418e8747082160f907b5043562425d909a13af0beacdb1e6')
+md5sums=('5197fcae0f2fb2ed223e92dae96497cc')
+sha512sums=('bc384cc9156ba6c54d3308ddad4d26b1877f020aa8558e82df2ed49ffa65e0fed5a49eaa11b27193bfe2ad11a4d7368f7cdbc225b820b309af3b299327ddb07b')
-prepare() {
- cd "${pkgname}-${pkgver}"
- patch -Np1 -i "$srcdir"/replace-sbin-with-usr-bin.patch
-}
+_SYSCONFDIR=/etc/openrc
package() {
@@ -34,11 +27,11 @@ package() {
# put service files in correct locations
for f in opentmpfiles-dev opentmpfiles-setup; do
- install -Dm755 openrc/$f.confd "$pkgdir"/etc/openrc/conf.d/$f
- install -Dm755 openrc/$f.initd "$pkgdir"/etc/openrc/init.d/$f
+ install -Dm755 openrc/$f.confd "$pkgdir"$_SYSCONFDIR/conf.d/$f
+ install -Dm755 openrc/$f.initd "$pkgdir"$_SYSCONFDIR/init.d/$f
done
- # activating the services is done in .install file
+ # activating the services should be done manually
# License is BSD 2 clause type and needs to be installed
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
diff --git a/opentmpfiles.install b/opentmpfiles.install
deleted file mode 100644
index 6265f6f6746d..000000000000
--- a/opentmpfiles.install
+++ /dev/null
@@ -1,15 +0,0 @@
-## arg 1: the new package version
-post_install() {
- echo "auto-enabling systemd-style tmpfiles support"
- /usr/bin/rc-update add opentmpfiles-dev sysinit
- /usr/bin/rc-update add opentmpfiles-setup boot
-}
-
-
-## arg 1: the old package version
-post_remove() {
- echo "disabling systemd-style tmpfiles support"
- /usr/bin/rc-update del opentmpfiles-dev sysinit
- /usr/bin/rc-update del opentmpfiles-setup boot
-
-}
diff --git a/replace-sbin-with-usr-bin.patch b/replace-sbin-with-usr-bin.patch
deleted file mode 100644
index 0f85afa65ad2..000000000000
--- a/replace-sbin-with-usr-bin.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -ura opentmpfiles-0.1.3.org/openrc/opentmpfiles-dev.initd opentmpfiles-0.1.3.new/openrc/opentmpfiles-dev.initd
---- opentmpfiles-0.1.3.org/openrc/opentmpfiles-dev.initd 2017-03-09 00:34:36.000000000 +0100
-+++ opentmpfiles-0.1.3.new/openrc/opentmpfiles-dev.initd 2017-03-12 14:44:24.788332295 +0100
-@@ -1,4 +1,4 @@
--#!/sbin/openrc-run
-+#!/usr/bin/openrc-run
- # Copyright 1999-2012 Gentoo Foundation
- # Released under the 2-clause BSD license.
-
-diff -ura opentmpfiles-0.1.3.org/openrc/opentmpfiles-setup.initd opentmpfiles-0.1.3.new/openrc/opentmpfiles-setup.initd
---- opentmpfiles-0.1.3.org/openrc/opentmpfiles-setup.initd 2017-03-09 00:34:36.000000000 +0100
-+++ opentmpfiles-0.1.3.new/openrc/opentmpfiles-setup.initd 2017-03-12 14:44:45.410427676 +0100
-@@ -1,4 +1,4 @@
--#!/sbin/openrc-run
-+#!/usr/bin/openrc-run
- # Copyright 1999-2012 Gentoo Foundation
- # Released under the 2-clause BSD license.
-