summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Hoeher2020-10-04 18:50:05 +0000
committerMartin Hoeher2020-10-04 18:50:05 +0000
commit5dae86b75b6fce8d2ad5e8aaea450da8f3f9a2ae (patch)
treea5399e0892340f97b182cd9d779921430b14aacd
parentac0972307415f62004a310ca463887b40e16efcf (diff)
downloadaur-5dae86b75b6fce8d2ad5e8aaea450da8f3f9a2ae.tar.gz
Update to v3.27.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73f038d295de..c8750e6e64e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opentodolist
pkgdesc = Maintain todo lists, notes and images in libraries, which can be synced via various services like NextCloud between your devices.
- pkgver = 3.25.0
- pkgrel = 2
+ pkgver = 3.27.0
+ pkgrel = 1
url = https://opentodolist.rpdev.net/
arch = x86_64
license = GPL
@@ -9,13 +9,14 @@ pkgbase = opentodolist
depends = qt5-base
depends = qt5-tools
depends = qt5-quickcontrols2
+ depends = qt5-remoteobjects
depends = syntax-highlighting
depends = libsecret
depends = ttf-roboto
depends = noto-fonts
provides = opentodolist
conflicts = opentodolist
- source = opentodolist::git+https://gitlab.com/rpdev/opentodolist.git#commit=ab0c2f7304bf57fd4e6e226e4c42381964ce6dd1
+ source = opentodolist::git+https://gitlab.com/rpdev/opentodolist.git#commit=8ead5bd5a9e29b7886e762a14211d513ea394b41
md5sums = SKIP
pkgname = opentodolist
diff --git a/PKGBUILD b/PKGBUILD
index f5f71bd065e2..155756592d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Martin Hoeher <martin@rpdev.net>
-# Automatically released from https://gitlab.com/rpdev/opentodolist/-/pipelines/186578590
+# Automatically released from https://gitlab.com/rpdev/opentodolist/-/pipelines/197914572
pkgname=opentodolist
-pkgver=3.26.0
+pkgver=3.27.0
pkgrel=2
pkgdesc="Maintain todo lists, notes and images in libraries, which can be synced via various services like NextCloud between your devices."
arch=('x86_64')
url="https://opentodolist.rpdev.net/"
license=('GPL')
groups=()
-depends=('qt5-base' 'qt5-tools' 'qt5-quickcontrols2' 'syntax-highlighting' 'libsecret' 'ttf-roboto' 'noto-fonts')
+depends=('qt5-base' 'qt5-tools' 'qt5-quickcontrols2' 'qt5-remoteobjects' 'syntax-highlighting' 'libsecret' 'ttf-roboto' 'noto-fonts')
makedepends=('git')
provides=("${pkgname%}")
conflicts=("${pkgname%}")
@@ -29,7 +29,7 @@ pkgver() {
if [ -n "$release_build" ]; then
printf "${pkgver}"
else
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --long --tags | cut -f1 -d'-')"
fi
}