summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel M. Dutra2023-09-20 15:23:47 -0300
committerGabriel M. Dutra2023-09-20 15:23:47 -0300
commited4cca273def058250feda01e9a0b79b2f8ee58f (patch)
tree8f022054b0840720010fea84a321def100a493ca
downloadaur-ed4cca273def058250feda01e9a0b79b2f8ee58f.tar.gz
opentofu-git: adding project
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d003b5625cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = opentofu-git
+ pkgdesc = OSS tool for building, changing, and versioning infrastructure safely and efficiently.
+ pkgver = r31726.90f7e52
+ pkgrel = 1
+ url = https://github.com/opentofu/opentofu
+ arch = x86_64
+ license = MPL2
+ makedepends = git
+ source = git+https://github.com/opentofu/opentofu.git
+ sha256sums = SKIP
+
+pkgname = opentofu-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f2dda727d211
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+opentofu
+src
+pkg
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9cb3dcde0ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Gabriel M. Dutra <nulldutra@proton.me>
+
+pkgname=opentofu-git
+pkgver=r31726.90f7e52
+pkgrel=1
+pkgdesc="OSS tool for building, changing, and versioning infrastructure safely and efficiently."
+url='https://github.com/opentofu/opentofu'
+arch=('x86_64')
+license=('MPL2')
+makedepends=('git')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd opentofu
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd opentofu
+ CGO_ENABLED=0 go build -ldflags "-w -s" -o bin/ .
+}
+
+package() {
+ cd opentofu
+ install -Dm755 bin/opentofu "$pkgdir/usr/bin/opentofu"
+}
+