summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2017-10-01 22:48:50 +0300
committercyrant2017-10-01 22:48:50 +0300
commit15c529b7be03176c8e5f1e4fa58c84386d19943f (patch)
tree2c0fe5b779f0eca540a7125028e5cec27a683b9c
downloadaur-15c529b7be03176c8e5f1e4fa58c84386d19943f.tar.gz
initial
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD46
-rw-r--r--opentoonz.desktop10
-rw-r--r--opentoonz.pngbin0 -> 10533 bytes
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..689167424023
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = opentoonz
+ pkgdesc = 2D animation software based on Toonz Studio Ghibli Version.
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://opentoonz.github.io
+ arch = x86_64
+ license = BSD
+ makedepends = boost
+ makedepends = boost-libs
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = cblas
+ depends = freeglut
+ depends = glew
+ depends = lzo
+ depends = qt5-multimedia
+ depends = qt5-script
+ depends = sdl2
+ depends = superlu
+ conflicts = opentoonz-git
+ source = git+https://github.com/opentoonz/opentoonz.git#tag=v1.1.3
+ source = opentoonz.desktop
+ source = opentoonz.png
+ md5sums = SKIP
+ md5sums = 79edaacc7ef2f7b932a2ab3e9234570e
+ md5sums = 3d8620258a66ee0f58c91ea6a38e33c1
+
+pkgname = opentoonz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..543acbdd90ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!*.desktop
+!*.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b92629fd0e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: cyrant <cyrant at tuta dot io>
+
+pkgname=opentoonz
+pkgver=1.1.3
+pkgrel=1
+pkgdesc='2D animation software based on Toonz Studio Ghibli Version.'
+url='https://opentoonz.github.io'
+license=('BSD')
+arch=('x86_64')
+conflicts=('opentoonz-git')
+depends=('cblas' 'freeglut' 'glew' 'lzo' 'qt5-multimedia' 'qt5-script' 'sdl2' 'superlu')
+makedepends=('boost' 'boost-libs' 'cmake' 'qt5-tools')
+source=(
+ "git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+)
+md5sums=(
+ 'SKIP'
+ '79edaacc7ef2f7b932a2ab3e9234570e'
+ '3d8620258a66ee0f58c91ea6a38e33c1'
+)
+
+build() {
+ cd "${pkgname}/thirdparty/tiff-4.0.3"
+ ./configure --with-pic --disable-jbig && make
+ cd -
+
+ cmake \
+ -H"${pkgname}/toonz/sources" \
+ -B"${pkgname}-build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cd "${pkgname}-build"
+ make
+}
+
+package() {
+ cd "${pkgname}-build"
+ make DESTDIR="${pkgdir}/" install
+ cd -
+
+ install -Dm644 "${pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/opentoonz.desktop b/opentoonz.desktop
new file mode 100644
index 000000000000..513615054d6e
--- /dev/null
+++ b/opentoonz.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=OpenToonz
+Comment=2D animation software
+Exec=opentoonz %f
+Icon=opentoonz
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Graphics;
diff --git a/opentoonz.png b/opentoonz.png
new file mode 100644
index 000000000000..6a79908f14cf
--- /dev/null
+++ b/opentoonz.png
Binary files differ