summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2020-02-01 20:26:26 +0400
committercyrant2020-02-01 20:26:26 +0400
commit94234e2f8acf6003dab36ebdc1971a18b67f47ac (patch)
tree31e1212da41074544dd25eb84bcb44d4f54f31e4
parent56d8f4a3f220c5dc2451c86fb14a325d06c73fcf (diff)
downloadaur-94234e2f8acf6003dab36ebdc1971a18b67f47ac.tar.gz
update to 1.4.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15df0f9f277a..801e9a9151b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opentoonz
pkgdesc = This is software for producing a 2D animation.
- pkgver = 1.3.0
- pkgrel = 3
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://opentoonz.github.io
arch = x86_64
license = BSD
@@ -17,13 +17,10 @@ pkgbase = opentoonz
depends = qt5-multimedia
depends = qt5-script
depends = qt5-svg
- depends = sdl2
depends = superlu
conflicts = opentoonz-git
- source = opentoonz-1.3.0.tar.gz::https://github.com/opentoonz/opentoonz/archive/v1.3.0.tar.gz
- source = opentoonz-build.patch::https://github.com/opentoonz/opentoonz/commit/adae1528d6f580d56b5499c97b30acfb84af4390.patch
- sha256sums = a5dd0286a58017a086a3533016b9b4f54ada25a230c62de63b995bc04d0cd5a8
- sha256sums = 9b8b4a68d3af0941ed83e655b68cf25037fedff24a53e3ae224b7f56337ab6f2
+ source = opentoonz-1.4.0.tar.gz::https://github.com/opentoonz/opentoonz/archive/v1.4.0.tar.gz
+ sha256sums = 176caca191bf2747964ecaf8cbb6be6a738fd04b464a2ba182b5aaf96ccaefa9
pkgname = opentoonz
diff --git a/PKGBUILD b/PKGBUILD
index f984be0636cb..55887210bc74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,22 @@
# Maintainer: cyrant <cyrant at tuta dot io>
pkgname=opentoonz
-pkgver=1.3.0
-pkgrel=3
+pkgver=1.4.0
+pkgrel=1
pkgdesc='This is software for producing a 2D animation.'
url='https://opentoonz.github.io'
license=('BSD')
arch=('x86_64')
conflicts=('opentoonz-git')
-depends=('cblas' 'freeglut' 'glew' 'hicolor-icon-theme' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
+depends=('cblas' 'freeglut' 'glew' 'hicolor-icon-theme' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'superlu')
makedepends=('boost' 'boost-libs' 'cmake' 'qt5-tools')
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/opentoonz/opentoonz/archive/v${pkgver}.tar.gz"
- "${pkgname}-build.patch::https://github.com/opentoonz/opentoonz/commit/adae1528d6f580d56b5499c97b30acfb84af4390.patch"
)
sha256sums=(
- 'a5dd0286a58017a086a3533016b9b4f54ada25a230c62de63b995bc04d0cd5a8'
- '9b8b4a68d3af0941ed83e655b68cf25037fedff24a53e3ae224b7f56337ab6f2'
+ '176caca191bf2747964ecaf8cbb6be6a738fd04b464a2ba182b5aaf96ccaefa9'
)
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch --forward --strip=1 --input="${srcdir}/${pkgname}-build.patch"
-}
-
build() {
cd "${srcdir}/${pkgname}-${pkgver}/thirdparty/tiff-4.0.3/"
./configure --with-pic --disable-jbig && make