summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyrant2019-01-30 23:01:16 +0400
committercyrant2019-01-30 23:01:16 +0400
commitb54ebb55e386dfcfaec0839af28321b40d6b9bb0 (patch)
treebdd8170bb679ccd594f9baa2fdb268de42a6d24c
parent5cac01cb03241549c55d6ff5f029ebd2808814c5 (diff)
downloadaur-b54ebb55e386dfcfaec0839af28321b40d6b9bb0.tar.gz
update to 1.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD37
-rw-r--r--opentoonz.desktop10
-rw-r--r--opentoonz.pngbin10533 -> 0 bytes
5 files changed, 18 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc7e796081a9..4797b6ad49ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opentoonz
- pkgdesc = 2D animation software based on Toonz Studio Ghibli Version.
- pkgver = 1.2.1
+ pkgdesc = This is software for producing a 2D animation.
+ pkgver = 1.3.0
pkgrel = 1
url = https://opentoonz.github.io
arch = x86_64
@@ -14,6 +14,7 @@ pkgbase = opentoonz
depends = cblas
depends = freeglut
depends = glew
+ depends = hicolor-icon-theme
depends = libmypaint
depends = qt5-multimedia
depends = qt5-script
@@ -21,12 +22,8 @@ pkgbase = opentoonz
depends = sdl2
depends = superlu
conflicts = opentoonz-git
- source = git+https://github.com/opentoonz/opentoonz.git#tag=v1.2.1
- source = opentoonz.desktop
- source = opentoonz.png
+ source = git+https://github.com/opentoonz/opentoonz.git#tag=v1.3.0
md5sums = SKIP
- md5sums = 79edaacc7ef2f7b932a2ab3e9234570e
- md5sums = 3d8620258a66ee0f58c91ea6a38e33c1
pkgname = opentoonz
diff --git a/.gitignore b/.gitignore
index 543acbdd90ed..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-!*.desktop
-!*.png
diff --git a/PKGBUILD b/PKGBUILD
index 39dd7e9dc12d..11212a83ae4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: cyrant <cyrant at tuta dot io>
pkgname=opentoonz
-pkgver=1.2.1
+pkgver=1.3.0
pkgrel=1
-pkgdesc='2D animation software based on Toonz Studio Ghibli Version.'
+pkgdesc='This is software for producing a 2D animation.'
url='https://opentoonz.github.io'
license=('BSD')
arch=('x86_64')
conflicts=('opentoonz-git')
-depends=('cblas' 'freeglut' 'glew' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
+depends=('cblas' 'freeglut' 'glew' 'hicolor-icon-theme' 'libmypaint' 'qt5-multimedia' 'qt5-script' 'qt5-svg' 'sdl2' 'superlu')
makedepends=('boost' 'boost-libs' 'cmake' 'git' 'pkgconf' 'qt5-tools')
-source=(
- "git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}"
- "${pkgname}.desktop"
- "${pkgname}.png"
-)
-md5sums=(
- 'SKIP'
- '79edaacc7ef2f7b932a2ab3e9234570e'
- '3d8620258a66ee0f58c91ea6a38e33c1'
-)
+source=("git+https://github.com/opentoonz/opentoonz.git#tag=v${pkgver}")
+md5sums=('SKIP')
build() {
- cd "${pkgname}/thirdparty/tiff-4.0.3"
+ cd "${srcdir}/${pkgname}/thirdparty/tiff-4.0.3/"
./configure --with-pic --disable-jbig && make
- cd -
-
+
+ cd "${srcdir}/"
cmake \
-H"${pkgname}/toonz/sources" \
-B"${pkgname}-build" \
@@ -33,16 +25,15 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DMYPAINT_LIB_INCLUDE_DIRS=/usr/include/libmypaint-1.3 \
-DMYPAINT_LIB_LDFLAGS=/usr/lib/libmypaint-1.3.so
- cd "${pkgname}-build"
+
+ cd "${srcdir}/${pkgname}-build/"
make
}
package() {
- cd "${pkgname}-build"
+ cd "${srcdir}/${pkgname}-build/"
make DESTDIR="${pkgdir}/" install
- cd -
-
- install -Dm644 "${pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+
+ cd "${srcdir}/${pkgname}/"
+ install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/opentoonz.desktop b/opentoonz.desktop
deleted file mode 100644
index 513615054d6e..000000000000
--- a/opentoonz.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=OpenToonz
-Comment=2D animation software
-Exec=opentoonz %f
-Icon=opentoonz
-Terminal=false
-Type=Application
-StartupNotify=true
-Categories=Graphics;
diff --git a/opentoonz.png b/opentoonz.png
deleted file mode 100644
index 6a79908f14cf..000000000000
--- a/opentoonz.png
+++ /dev/null
Binary files differ