summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCampbell Barton2017-11-30 17:28:34 +1100
committerCampbell Barton2017-11-30 17:28:34 +1100
commitea5bb1444f24b907b5b5e722452d5353accaf2f9 (patch)
tree44828a926ebe4aea70929c8ff516fe93083cbec0
parentbb49f0825cad4052fc8b992bc9b84fec6210df2d (diff)
downloadaur-ea5bb1444f24b907b5b5e722452d5353accaf2f9.tar.gz
Include libmypaint
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e20f5f5e6a97..825a1b5fc9e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = opentoonz-git
pkgdesc = 2D Animation software.
- pkgver = 1.1.2.877
+ pkgver = 1.1.3.1250
pkgrel = 1
url = https://github.com/opentoonz/opentoonz
arch = i686
@@ -9,6 +9,7 @@ pkgbase = opentoonz-git
makedepends = cmake
makedepends = make
makedepends = git
+ makedepends = git-lfs
depends = boost
depends = boost-libs
depends = qt5-base
@@ -27,6 +28,7 @@ pkgbase = opentoonz-git
depends = blas
depends = cblas
depends = superlu
+ depends = libmypaint
source = git+https://github.com/opentoonz/opentoonz.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3ceddef2014f..bf335b3f6d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Campbell Barton <ideasman42@gmail.com>
-
+export GIT_LFS_SKIP_SMUDGE=1
_pkgname=opentoonz
_version=git
-pkgver=1.1.2.877
+pkgver=1.1.3.1250
pkgname=${_pkgname}-${_version}
pkgrel=1
pkgdesc="2D Animation software."
@@ -16,8 +16,9 @@ depends=(
'qt5-base' 'qt5-svg' 'qt5-script' 'qt5-tools' 'qt5-multimedia'
'lz4' 'libusb' 'lzo' 'libjpeg-turbo'
'glew' 'freeglut' 'sdl2' 'freetype2'
- 'blas' 'cblas' 'superlu')
-makedepends=('cmake' 'make' 'git')
+ 'blas' 'cblas' 'superlu' 'libmypaint')
+# note: ideally we could avoid git-lfs since we don't need any files it provides
+makedepends=('cmake' 'make' 'git' 'git-lfs')
optdepends=()
provides=()
conflicts=()
@@ -53,7 +54,7 @@ pkgver() {
build() {
# make libtiff
cd $_pkgname/thirdparty/tiff-4.0.3
- CFLAGS="-fPIC" ./configure && make $MAKEFLAGS
+ ./configure --with-pic --disable-jbig && make $MAKEFLAGS
cd -
cmake -H$_pkgname/toonz/sources \