summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-08-18 23:20:01 +0200
committersmls2015-08-18 23:20:01 +0200
commitfe96a7754ac18827213b8647c81871bddf80d48c (patch)
tree8526d776ce370bed1fa1164604a52c9ed2dafd73
parente6bd1cda0109231ef43d1db76cb4be5c7333c559 (diff)
downloadaur-fe96a7754ac18827213b8647c81871bddf80d48c.tar.gz
update to new filename scheme
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94721f216b1f..f482726a619d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openttd-opengfx-snapshot
pkgdesc = A free graphics set for openttd (latest snapshot release)
- pkgver = 0.5.1+s20141109
+ pkgver = 0.5.2+s20150519
pkgrel = 1
url = http://dev.openttdcoop.org/projects/opengfx
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index a4a445a796b5..ff572465dede 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Inspired by the netbeans-nightly PKGBUILD by Pavol Hluchy (Lopo) <lopo at losys dot eu>
pkgname=openttd-opengfx-snapshot
-pkgver=0.5.1+s20141109
+pkgver=0.5.2+s20150519
pkgrel=1
pkgdesc='A free graphics set for openttd (latest snapshot release)'
arch=('any')
@@ -27,16 +27,17 @@ pkgver() {
prepare() {
cd "${SRCDEST}"
_snapshotnum="$(grep -Po '^NEWGRF_VERSION.*?:\K.*' custom_tags.txt)"
- _file="opengfx-${_snapshotnum}.zip"
- download_file "${_webroot}/${_file}"
+ _file="opengfx-v${_snapshotnum}"
+ msg2 "${_webroot}/${_file}.zip"
+ download_file "${_webroot}/${_file}.zip"
cd "$srcdir"
- extract_file "${_file}"
+ extract_file "${_file}.zip"
+ tar xvf "${_file}.tar"
+ mv -T "${_file}" opengfx
}
package() {
- cd "${srcdir}"
- tar xvf "opengfx.tar"
cd opengfx
install -d "${pkgdir}"/usr/share/openttd/data
install -m644 *.grf "${pkgdir}"/usr/share/openttd/data