summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjapernilater2015-08-07 21:22:45 -0500
committerjapernilater2015-08-07 21:22:45 -0500
commit4ba686c6040dfa4e66eadc16256c1b312aa7fa29 (patch)
treef2d338241229ef242256cd517014d7752867fd20
parent3e96aee8b88854964e97a1f6420a2fab6ddcae6e (diff)
downloadaur-4ba686c6040dfa4e66eadc16256c1b312aa7fa29.tar.gz
Updated to 2.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd1f1623729e..b2c4b1116a5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = opentx-companion
pkgdesc = EEPROM Editor for OpenTX RC transmitter firmwares
- pkgver = 2.1.0
- pkgrel = 2
+ pkgver = 2.1.1
+ pkgrel = 1
url = http://www.open-tx.org/
arch = x86_64
license = GPL
@@ -20,8 +20,8 @@ pkgbase = opentx-companion
provides = companion
conflicts = companion
conflicts = companion9x-svn
- source = https://github.com/opentx/opentx/archive/2.1.0.tar.gz
- md5sums = f27377d3efa735bb01f90b0699e742a0
+ source = https://github.com/opentx/opentx/archive/2.1.1.tar.gz
+ md5sums = 5da1a217a41b6f283e137a5f6b222a26
pkgname = opentx-companion
diff --git a/PKGBUILD b/PKGBUILD
index dcaabd92ff18..b2e43a5e515b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jeff Youdontneedtoknow <jeffpublicjr at gmail dot com>
pkgname=opentx-companion
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.1.1
+pkgrel=1
pkgdesc="EEPROM Editor for OpenTX RC transmitter firmwares"
arch=('x86_64')
url="http://www.open-tx.org/"
@@ -11,7 +11,7 @@ makedepends=('subversion' 'cmake' 'xsd' 'python2-pyqt4' 'bc' 'python2' 'avr-gcc'
provides=('companion')
conflicts=('companion' 'companion9x-svn')
source=(https://github.com/opentx/opentx/archive/$pkgver.tar.gz)
-md5sums=('f27377d3efa735bb01f90b0699e742a0')
+md5sums=('5da1a217a41b6f283e137a5f6b222a26')
build() {
sed -i -e 's/env python/env python2.7/' $srcdir/opentx-$pkgver/radio/util/*.py
@@ -22,12 +22,15 @@ build() {
cmake ../src
make clean
make
+ mv $srcdir/opentx-$pkgver/companion/lbuild/companion.desktop $srcdir/opentx-$pkgver/companion/src/companion.desktop
sed -i -e 's/Categories=Application/Categories=Development;/' $srcdir/opentx-$pkgver/companion/src/companion.desktop
+ sed -i -e 's/Icon=companion21/Icon=companion/' $srcdir/opentx-$pkgver/companion/src/companion.desktop
+ sed -i -e 's/Name=Companion 2.1.1/Name=Companion/' $srcdir/opentx-$pkgver/companion/src/companion.desktop
}
package() {
cd $srcdir/opentx-$pkgver/companion/
- install -Dm755 lbuild/companion $pkgdir/usr/bin/companion
+ install -Dm755 lbuild/companion21 $pkgdir/usr/bin/companion21
install -Dm644 src/companion.desktop $pkgdir/usr/share/applications/companion.desktop
install -Dm644 src/icon.png $pkgdir/usr/share/icons/companion.png
} \ No newline at end of file