summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMinze Zwerver2017-06-02 22:00:28 +0200
committerMinze Zwerver2017-06-02 22:00:28 +0200
commit806edc5a0178090a328805c0bcbb94a1c51ba93f (patch)
treedcd83c20da9002c82c6c3d3fa6f32c4f2e3bbd25
parent1a4f16ac05cb45eb825193eccbd849e2d4138341 (diff)
downloadaur-806edc5a0178090a328805c0bcbb94a1c51ba93f.tar.gz
update to version 2.2 & qt4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--cmake_version.diff24
3 files changed, 44 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12bee97550d..0da244e3b48e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = opentx-companion
pkgdesc = EEPROM Editor for OpenTX RC transmitter firmwares
- pkgver = 2.1.9
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = http://www.open-tx.org/
arch = x86_64
license = GPL
makedepends = cmake
makedepends = xsd
- makedepends = python-pyqt4
makedepends = bc
makedepends = python
makedepends = avr-gcc
makedepends = avr-libc
makedepends = sed
- depends = phonon-qt4
- depends = qt4
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-svg
depends = sdl
provides = companion
conflicts = companion
conflicts = companion9x-svn
- source = https://github.com/opentx/opentx/archive/2.1.9.tar.gz
- md5sums = 470e5ebdb06a8491a1718a2c049b772d
+ source = https://github.com/opentx/opentx/archive/2.2.0.tar.gz
+ sha256sums = 27a07efcbb7d5759bafea7d8a6d97f910c2830881c0d4c71cbbc7da65446b2cd
pkgname = opentx-companion
diff --git a/PKGBUILD b/PKGBUILD
index bddc63ca54aa..fb566dd9cca7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,38 @@
# Previous Maintainer: Jeff Youdontneedtoknow <jeffpublicjr at gmail dot com>
# Contributer: Arnaud
pkgname=opentx-companion
-pkgver=2.1.9
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc="EEPROM Editor for OpenTX RC transmitter firmwares"
arch=('x86_64')
url="http://www.open-tx.org/"
license=('GPL')
-depends=('phonon-qt4' 'qt4' 'sdl')
-makedepends=('cmake' 'xsd' 'python-pyqt4' 'bc' 'python' 'avr-gcc' 'avr-libc' 'sed')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-svg' 'sdl')
+makedepends=('cmake' 'xsd' 'bc' 'python' 'avr-gcc' 'avr-libc' 'sed')
provides=('companion')
conflicts=('companion' 'companion9x-svn')
source=("https://github.com/opentx/opentx/archive/$pkgver.tar.gz"
)
-md5sums=('470e5ebdb06a8491a1718a2c049b772d'
+sha256sums=('27a07efcbb7d5759bafea7d8a6d97f910c2830881c0d4c71cbbc7da65446b2cd'
)
build() {
- cd $srcdir/opentx-$pkgver/companion
+ cd $srcdir/opentx-$pkgver
+ patch -p1 -i ../../cmake_version.diff
+
+# cd $srcdir/opentx-$pkgver/
mkdir -p lbuild
cd lbuild
- cmake -DCMAKE_INSTALL_PREFIX=/usr ../src
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DFIRMWARE_TARGET=OFF ../
make
}
-#prepare() {
-# cd $srcdir/opentx-$pkgver
-# patch -p1 -i ../opentx-$pkgver-gcc6.patch
-#}
package() {
- cd $srcdir/opentx-$pkgver/companion/lbuild
+ cd $srcdir/opentx-$pkgver/lbuild
make DESTDIR=$pkgdir/ install
cd $pkgdir/usr/share/applications
- sed -i -e 's/Categories=Application/Categories=Development;/' companion21.desktop
- sed -i -e 's/Categories=Application/Categories=Development;/' simulator21.desktop
+ sed -i -e 's/Categories=Application/Categories=Development;/' companion22.desktop
+ sed -i -e 's/Categories=Application/Categories=Development;/' simulator22.desktop
rm -Rf $pkgdir/lib
}
diff --git a/cmake_version.diff b/cmake_version.diff
new file mode 100644
index 000000000000..9d335edf3f9f
--- /dev/null
+++ b/cmake_version.diff
@@ -0,0 +1,24 @@
+diff -ur opentx-2.2.0/CMakeLists.txt opentx-2.2.0.nw/CMakeLists.txt
+--- opentx-2.2.0/CMakeLists.txt 2017-05-30 18:37:38.000000000 +0200
++++ opentx-2.2.0.nw/CMakeLists.txt 2017-06-02 20:56:55.412833803 +0200
+@@ -9,7 +9,7 @@
+ set(SDCARD_REVISION "0010")
+ set(SDCARD_VERSION ${VERSION_MAJOR}.${VERSION_MINOR}V${SDCARD_REVISION})
+
+-cmake_minimum_required(VERSION 2.8)
++cmake_minimum_required(VERSION 3.8)
+ cmake_policy(SET CMP0020 NEW)
+ cmake_policy(SET CMP0023 OLD)
+ if(POLICY CMP0042)
+diff -ur opentx-2.2.0/companion/src/CMakeLists.txt opentx-2.2.0.nw/companion/src/CMakeLists.txt
+--- opentx-2.2.0/companion/src/CMakeLists.txt 2017-06-02 21:39:16.665770555 +0200
++++ opentx-2.2.0.nw/companion/src/CMakeLists.txt 2017-05-30 18:37:38.000000000 +0200
+@@ -95,7 +95,7 @@
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${WARNING_FLAGS}")
+
+-use_cxx11() # ensure gnu++11 in CXX_FLAGS with CMake < 3.1
++#use_cxx11() # ensure gnu++11 in CXX_FLAGS with CMake < 3.1
+
+ include_directories(
+ ${CMAKE_BINARY_DIR}