summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Meyer2019-06-13 09:45:57 -0400
committerAlex Meyer2019-06-13 09:45:57 -0400
commit415d2672d63b202d777f54e510ba43a77b8d2be8 (patch)
tree4277a3c31cd164f028b1bec9558c690dbbbe9ab3
downloadaur-415d2672d63b202d777f54e510ba43a77b8d2be8.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--opentx-companion-bin.install13
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c19fd578449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = opentx-companion-bin
+ pkgdesc = Models and settings editor for the OpenTX open source firmware.
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = http://www.open-tx.org/
+ install = opentx-companion-bin.install
+ arch = x86_64
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = qt5-base>=5.7.0
+ depends = qt5-multimedia>=5.6.0beta
+ depends = qt5-svg>=5.6.0beta
+ depends = sdl>=1.2.11
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://downloads.open-tx.org/2.2/release/companion/linux/companion22_2.2.3_amd64.deb
+ sha512sums_x86_64 = a4f68062b0a86d07f9fe7541f7c4e383e050baef058b8de8294ee18fc365dbfe5ffe5bece5d8c430a822a0096282eb454c08cd5fa72e1af8b66afeac68695868
+
+pkgname = opentx-companion-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5172b16d724
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Generated by debtap
+# Maintainer: Alex
+# Contributor: Alex
+pkgname=('opentx-companion-bin')
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="Models and settings editor for the OpenTX open source firmware."
+arch=('x86_64')
+url="http://www.open-tx.org/"
+license=('GPL')
+depends=('hicolor-icon-theme' 'qt5-base>=5.7.0' 'qt5-multimedia>=5.6.0beta' 'qt5-svg>=5.6.0beta' 'sdl>=1.2.11')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://downloads.open-tx.org/2.2/release/companion/linux/companion22_${pkgver}_amd64.deb")
+sha512sums_x86_64=('a4f68062b0a86d07f9fe7541f7c4e383e050baef058b8de8294ee18fc365dbfe5ffe5bece5d8c430a822a0096282eb454c08cd5fa72e1af8b66afeac68695868')
+
+package(){
+
+ # Extract package data
+ tar xzf data.tar.gz -C "${pkgdir}"
+
+ # Fix directories structure differencies
+ cd "${pkgdir}"
+
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+ sed -i -e 's:^Exec=/usr/local/bin/:Exec=/usr/bin/:g' "usr/share/applications/companion22.desktop"
+ sed -i -e 's:^Exec=/usr/local/bin/:Exec=/usr/bin/:g' "usr/share/applications/simulator22.desktop"
+ mkdir -p usr/lib 2> /dev/null; mv lib/* usr/lib; rm -rf lib
+ mv usr/local/lib/* usr/lib; rm -rf usr/local/lib
+
+ cd ..
+
+}
diff --git a/opentx-companion-bin.install b/opentx-companion-bin.install
new file mode 100644
index 000000000000..a3ff5b674f7e
--- /dev/null
+++ b/opentx-companion-bin.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}