summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2022-03-09 21:56:18 -0500
committerPatrick Northon2022-03-09 21:56:18 -0500
commitbccc61f73dfea9f20d7e56cfb6a6954228bc15be (patch)
treeaf9fea3180805967e8f5f582f5f5ad20eb98bb68
parent496f9eb02b0404eb0f0eaf4b2996764164831791 (diff)
downloadaur-bccc61f73dfea9f20d7e56cfb6a6954228bc15be.tar.gz
Update version.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f76b1bddc68d..7ca9017ccd41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = opentyrian
pkgdesc = Open Source port of the classic DOS shoot-em-up Tyrian
- pkgver = 2.1.20130907.r119.g650e1f7
- pkgrel = 2
+ pkgver = 2.1.20220309
+ pkgrel = 1
url = https://github.com/opentyrian/opentyrian
arch = i686
arch = x86_64
license = GPL2
- makedepends = git
depends = sdl2
depends = sdl2_net
optdepends = hicolor-icon-theme: .desktop file icons
provides = tyrian
- source = git+https://github.com/opentyrian/opentyrian#commit=650e1f72fd18d2242d10d706afa7f77f80151aea
+ source = opentyrian-2.1.20220309.tar.gz::https://github.com/opentyrian/opentyrian/archive/refs/tags/v2.1.20220309.tar.gz
source = http://camanis.net/tyrian/tyrian21.zip
- sha256sums = SKIP
+ sha256sums = 9d28a21f982a88ff26f433ab9cd48f4e394322658333cf71e219321f166826b7
sha256sums = 7790d09a2a3addcd33c66ef063d5900eb81cc9c342f4807eb8356364dd1d9277
pkgname = opentyrian
-
diff --git a/PKGBUILD b/PKGBUILD
index 464980823f44..a5b0937fbc9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,33 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgname=opentyrian
-pkgver=2.1.20130907.r119.g650e1f7
-pkgrel=2
-pkgdesc="Open Source port of the classic DOS shoot-em-up Tyrian"
-url="https://github.com/opentyrian/opentyrian"
+pkgver=2.1.20220309
+pkgrel=1
+pkgdesc='Open Source port of the classic DOS shoot-em-up Tyrian'
+url="https://github.com/$pkgname/$pkgname"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('sdl2' 'sdl2_net')
-makedepends=('git')
provides=('tyrian')
optdepends=('hicolor-icon-theme: .desktop file icons')
-source=("git+https://github.com/opentyrian/opentyrian#commit=650e1f72fd18d2242d10d706afa7f77f80151aea"
- "http://camanis.net/tyrian/tyrian21.zip")
-sha256sums=('SKIP'
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/$pkgname/$pkgname/archive/refs/tags/v${pkgver}.tar.gz"
+ 'http://camanis.net/tyrian/tyrian21.zip')
+sha256sums=('9d28a21f982a88ff26f433ab9cd48f4e394322658333cf71e219321f166826b7'
'7790d09a2a3addcd33c66ef063d5900eb81cc9c342f4807eb8356364dd1d9277')
-pkgver() {
- cd "$pkgname"
- git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+_srcdir="${pkgname}-${pkgver}"
+
+prepare() {
+ cd "$_srcdir"
+ sed -i 's/CREDITS//' 'Makefile'
}
build() {
- make prefix=/usr all -C $pkgname
+ make prefix=/usr all -C "$_srcdir"
}
package() {
- cd "$pkgname"
+ cd "$_srcdir"
make DESTDIR="$pkgdir" prefix=/usr install
install -Dm644 "linux/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
@@ -38,7 +39,7 @@ package() {
"$pkgdir/usr/share/icons/hicolor/${_x}x${_x}/apps/$pkgname.png"
done
- cd ../tyrian21
+ cd "$srcdir/tyrian21"
install -Dt "$pkgdir/usr/share/games/tyrian" -m644 *.dat *.lvl *.shp *.snd \
demo.* music.mus tyrend.anm tyrian.{cdt,hdt,pic} tshp2.pcx
}