summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincenzo Maffione2018-10-30 18:05:12 +0100
committerVincenzo Maffione2018-10-31 12:24:22 +0100
commit816f617d76265a5163c7a71634874270aca20ef5 (patch)
tree69fa195a66e8ca1869ed2775f2934fd53d5f086a
downloadaur-816f617d76265a5163c7a71634874270aca20ef5.tar.gz
PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f08b2e66323
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = openucx
+ pkgdesc = Unified Communication X (http://www.openucx.org)
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = http://www.openucx.org
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = rdma-core
+ source = git+https://github.com/openucx/ucx.git#tag=v1.4.0
+ md5sums = SKIP
+
+pkgname = openucx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0568163184fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Vincenzo Maffione <v.maffione at gmail dot com>
+
+pkgname=openucx
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Unified Communication X (http://www.openucx.org)"
+arch=('any')
+url="http://www.openucx.org"
+license=('BSD')
+depends=('rdma-core')
+makedepends=('git')
+source=('git+https://github.com/openucx/ucx.git#tag=v1.4.0')
+noextract=()
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/ucx
+ ./autogen.sh
+ ./contrib/configure-release --prefix=/usr
+ make
+}
+
+file_is_elf()
+{
+ local filename=$1
+ ELF="1"
+ readelf -h "$filename" > /dev/null 2>&1 || ELF="0"
+ echo "$ELF"
+}
+
+package() {
+ cd "$srcdir"/ucx
+ make DESTDIR="$pkgdir/" install
+}