summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurifier2017-02-17 12:22:52 -0500
committerAurifier2017-02-17 12:22:52 -0500
commitc7afe1ae7d67749cdaaf5fdc379f11d31b916644 (patch)
tree11ec85bcce33dab9df159d7f407cf2e483ec7b2b
downloadaur-c7afe1ae7d67749cdaaf5fdc379f11d31b916644.tar.gz
Initial stab at getting a working package
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
-rw-r--r--include_unistd.patch10
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69ac4e8d2184
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = openuru-moss
+ pkgdesc = MOSS is a UNIX-based server for the Myst Online: Uru Live client
+ pkgver = r41+.3e78d60a5282+
+ pkgrel = 1
+ url = openuru.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpqxx
+ depends = postgresql
+ source = openuru-moss::hg+http://foundry.openuru.org/hg/MOSS
+ source = include_unistd.patch
+ md5sums = SKIP
+ md5sums = 923b06d8c25265679bd35e532118f2ff
+
+pkgname = openuru-moss
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beb6b8cbfc11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Drew Reed <reed.995@osu.edu>
+pkgname=openuru-moss
+pkgver=r41+.3e78d60a5282+
+pkgrel=1
+pkgdesc="MOSS is a UNIX-based server for the Myst Online: Uru Live client"
+arch=('i686' 'x86_64')
+url="openuru.org"
+license=('GPL')
+depends=('libpqxx'
+ 'postgresql')
+makedepends=()
+backup=()
+source=("$pkgname::hg+http://foundry.openuru.org/hg/MOSS"
+ "include_unistd.patch")
+md5sums=('SKIP'
+ '923b06d8c25265679bd35e532118f2ff')
+
+prepare() {
+ cd "$srcdir"
+ patch -p0 -i "include_unistd.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./bootstrap.sh
+ ./configure --prefix=/usr --enable-fast-download
+ make
+ cd "postgresql"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+ cd "postgresql"
+ make DESTDIR="$pkgdir/" install
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
diff --git a/include_unistd.patch b/include_unistd.patch
new file mode 100644
index 000000000000..53a047166dfa
--- /dev/null
+++ b/include_unistd.patch
@@ -0,0 +1,10 @@
+--- openuru-moss/moss_serv.h 2017-02-15 13:02:13.478011579 -0500
++++ openuru-moss/moss_serv.h.foo 2017-02-15 13:15:37.459520711 -0500
+@@ -23,6 +23,7 @@
+ * The serv_main() function, declared at the end, is the main loop.
+ */
+
++#include <unistd.h>
+ //#include <pthread.h>
+ //#include <signal.h>
+ //