summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHitCoder97682022-06-28 01:05:26 +0100
committerHitCoder97682022-06-28 01:05:26 +0100
commitbdf98a87277c336848c805f0e63a4f7cd0ae6310 (patch)
treea3d5ee7df7c9cde48227285dcda963846c32ffdb
parentb187c3bfd26f03fece1c30fc7e71b577f0ae34e3 (diff)
downloadaur-bdf98a87277c336848c805f0e63a4f7cd0ae6310.tar.gz
fix installer not running openutau if it wasn't yet installed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--openutau11
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 839c34f53edc..312d7b57b45d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,7 +21,7 @@ pkgbase = openutau-installer
source = OpenUtau.desktop
source = openutau.svg
sha256sums = SKIP
- sha256sums = 69b397c5d7ce8be3da393071503b1b894b32225a9b1b377a9a09045a8f811d5a
+ sha256sums = daa0115af49f653400b7ef5bd6795d7cb703834bb9503584b4551f9a416682e7
sha256sums = 6c2939d1126db03e744deceed9464a4d4d25c03a17c1f2d7585697f1fc2a5f17
sha256sums = 490fd7489bb3c4225c3f2d1e96ba8320bd481da6eb031b97229dcf06997c2f5b
diff --git a/PKGBUILD b/PKGBUILD
index 76785743ba60..53dc4dd231f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ source=("https://github.com/stakira/OpenUtau/releases/download/OpenUtau-Latest/O
"OpenUtau.desktop"
"openutau.svg")
sha256sums=('SKIP'
- '69b397c5d7ce8be3da393071503b1b894b32225a9b1b377a9a09045a8f811d5a'
+ 'daa0115af49f653400b7ef5bd6795d7cb703834bb9503584b4551f9a416682e7'
'6c2939d1126db03e744deceed9464a4d4d25c03a17c1f2d7585697f1fc2a5f17'
'490fd7489bb3c4225c3f2d1e96ba8320bd481da6eb031b97229dcf06997c2f5b')
diff --git a/openutau b/openutau
index 78677d854ccb..b7343fc343ed 100644
--- a/openutau
+++ b/openutau
@@ -1,11 +1,12 @@
#! /bin/bash
-# Check if OpenUtau is installed, and run it if so
-if [ -d "$HOME/.openutau" ] && [ -f "$HOME/.openutau/OpenUtau" ]; then
- exec ~/.openutau/OpenUtau
-else
+# Check if OpenUtau is installed, install it if not
+if [ ! -d "$HOME/.openutau" ] && [ ! -f "$HOME/.openutau/OpenUtau" ]; then
# copy openutau from libs to user directory
cp -r /usr/lib/openutau-installer/openutau ~/.openutau
# this allows the application to update itself per local user installation.
-fi \ No newline at end of file
+fi
+
+# run openutau
+exec ~/.openutau/OpenUtau \ No newline at end of file