summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-06-21 18:00:46 -0300
committerDaniel Bermond2024-06-21 18:00:46 -0300
commit28ae3b47e9dc6d477842b478dc32451a28bd318b (patch)
treeb24875aca55292d8aff0a027f2e1b98e5522da42
parentd2afe16c0791a82593c324dc6687a94949fde2d2 (diff)
downloadaur-28ae3b47e9dc6d477842b478dc32451a28bd318b.tar.gz
Update to version 2024.2.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c150985bdd29..29c6b3bcc979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openvino
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications
- pkgver = 2024.1.0
- pkgrel = 3
+ pkgver = 2024.2.0
+ pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
license = Apache-2.0
@@ -15,7 +15,6 @@ pkgbase = openvino
makedepends = snappy
makedepends = python
makedepends = python-setuptools
- makedepends = cython
makedepends = fdupes
makedepends = patchelf
makedepends = shellcheck
@@ -25,15 +24,15 @@ pkgbase = openvino
optdepends = ocl-icd: for Intel GPU plugin
optdepends = level-zero-loader: for Intel NPU plugin
optdepends = snappy: for tensorflow frontend
- optdepends = protobuf: for tensorflow, paddle and onnx frontends
optdepends = python: for Python API
optdepends = python-numpy: for Python API
- optdepends = cython: for Python API
+ optdepends = python-packaging: for Python API
+ optdepends = python-pillow: for Python API
provides = intel-openvino
conflicts = intel-openvino
replaces = intel-openvino
options = !emptydirs
- source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.1.0
+ source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.2.0
source = oneDNN-openvinotoolkit::git+https://github.com/openvinotoolkit/oneDNN.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/madler/zlib.git
@@ -58,11 +57,13 @@ pkgbase = openvino
source = git+https://github.com/oneapi-src/level-zero.git
source = git+https://github.com/intel/level-zero-npu-extensions.git
source = git+https://github.com/openvinotoolkit/telemetry.git
+ source = git+https://github.com/libxsmm/libxsmm.git
source = openvino.conf
source = setupvars.sh
source = 010-openvino-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
- sha256sums = edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3
+ sha256sums = 60a83d96f8a22361699d536298ad6f2697fb27fefd4ee2710f807e9beaff53bf
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9f3b1b55cd40..a1dc1377c1a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2024.1.0
-pkgrel=3
+pkgver=2024.2.0
+pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
url='https://docs.openvinotoolkit.org/'
@@ -15,13 +15,12 @@ optdepends=('intel-compute-runtime: for Intel GPU plugin'
'ocl-icd: for Intel GPU plugin'
'level-zero-loader: for Intel NPU plugin'
'snappy: for tensorflow frontend'
- 'protobuf: for tensorflow, paddle and onnx frontends'
'python: for Python API'
'python-numpy: for Python API'
- 'cython: for Python API')
+ 'python-packaging: for Python API'
+ 'python-pillow: for Python API')
makedepends=('git' 'git-lfs' 'cmake' 'opencl-clhpp' 'opencl-headers' 'ocl-icd' 'opencv'
- 'snappy' 'python' 'python-setuptools' 'cython' 'fdupes' 'patchelf'
- 'shellcheck')
+ 'snappy' 'python' 'python-setuptools' 'fdupes' 'patchelf' 'shellcheck')
provides=('intel-openvino')
conflicts=('intel-openvino')
replaces=('intel-openvino')
@@ -51,11 +50,13 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/oneapi-src/level-zero.git'
'git+https://github.com/intel/level-zero-npu-extensions.git'
'git+https://github.com/openvinotoolkit/telemetry.git'
+ 'git+https://github.com/libxsmm/libxsmm.git'
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3'
+sha256sums=('60a83d96f8a22361699d536298ad6f2697fb27fefd4ee2710f807e9beaff53bf'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -116,6 +117,7 @@ prepare() {
git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
+ git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/libxsmm.url "${srcdir}/libxsmm"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
@@ -123,6 +125,11 @@ prepare() {
}
build() {
+ # fix warning: "_FORTIFY_SOURCE" redefined
+ # note: upstream forces _FORTIFY_SOURCE=2
+ export CFLAGS="${CFLAGS/-Wp,-D_FORTIFY_SOURCE=?/}"
+ export CXXFLAGS="${CXXFLAGS/-Wp,-D_FORTIFY_SOURCE=?/}"
+
# note: does not accept 'None' build type
cmake -B build -S openvino \
-G 'Unix Makefiles' \