summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-04-25 19:35:31 -0300
committerDaniel Bermond2024-04-25 19:35:31 -0300
commit44ca29fafdc25e9aa634af0146fe1b3b89edf09a (patch)
tree928a62889319b4b24bbdde76351823dcca761e98
parentae1d113bb317db6e228af78549914c5ee1a18bfd (diff)
downloadaur-44ca29fafdc25e9aa634af0146fe1b3b89edf09a.tar.gz
Update to version 2024.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--010-openvino-disable-werror.patch2
-rw-r--r--020-openvino-use-protobuf-shared-libs.patch2
-rw-r--r--PKGBUILD17
4 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d98b5c1f4da3..6a500334f2a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvino
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications
- pkgver = 2024.0.0
+ pkgver = 2024.1.0
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = openvino
conflicts = intel-openvino
replaces = intel-openvino
options = !emptydirs
- source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.0.0
+ source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.1.0
source = oneDNN-openvinotoolkit::git+https://github.com/openvinotoolkit/oneDNN.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/madler/zlib.git
@@ -54,10 +54,16 @@ pkgbase = openvino
source = git+https://github.com/google/snappy.git
source = git+https://github.com/ARM-software/ComputeLibrary.git
source = git+https://github.com/openvinotoolkit/mlas.git
+ source = git+https://github.com/oneapi-src/level-zero.git
+ source = git+https://github.com/intel/level-zero-npu-extensions.git
+ source = git+https://github.com/openvinotoolkit/telemetry.git
source = openvino.conf
source = setupvars.sh
source = 010-openvino-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
+ sha256sums = edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -82,7 +88,7 @@ pkgbase = openvino
sha256sums = SKIP
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
- sha256sums = 1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e
- sha256sums = 17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a
+ sha256sums = 0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132
+ sha256sums = 2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb
pkgname = openvino
diff --git a/010-openvino-disable-werror.patch b/010-openvino-disable-werror.patch
index d62e0e81b504..2a168ec344d8 100644
--- a/010-openvino-disable-werror.patch
+++ b/010-openvino-disable-werror.patch
@@ -1,6 +1,6 @@
--- a/src/plugins/intel_gpu/CMakeLists.txt
+++ b/src/plugins/intel_gpu/CMakeLists.txt
-@@ -37,10 +37,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
+@@ -46,10 +46,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
add_subdirectory(thirdparty)
include(thirdparty/cmake/rapidjson.cmake)
diff --git a/020-openvino-use-protobuf-shared-libs.patch b/020-openvino-use-protobuf-shared-libs.patch
index eb6341f2870f..b72bd88db4ff 100644
--- a/020-openvino-use-protobuf-shared-libs.patch
+++ b/020-openvino-use-protobuf-shared-libs.patch
@@ -1,6 +1,6 @@
--- a/thirdparty/dependencies.cmake
+++ b/thirdparty/dependencies.cmake
-@@ -307,7 +307,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
+@@ -318,7 +318,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
# Note: Debian / Ubuntu / RHEL libprotobuf.a can only be used with -DBUILD_SHARED_LIBS=OFF
# because they are compiled without -fPIC
if(NOT DEFINED Protobuf_USE_STATIC_LIBS)
diff --git a/PKGBUILD b/PKGBUILD
index 0e9fb1daf09e..1db2804029bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2024.0.0
+pkgver=2024.1.0
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
@@ -47,11 +47,17 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'git+https://github.com/google/snappy.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/openvinotoolkit/mlas.git'
+ 'git+https://github.com/oneapi-src/level-zero.git'
+ 'git+https://github.com/intel/level-zero-npu-extensions.git'
+ 'git+https://github.com/openvinotoolkit/telemetry.git'
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
'020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('SKIP'
+sha256sums=('edf2a719de99981396784da9e42483a16c8a2e24453780693cc69d452b4b45b3'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP'
'SKIP'
'SKIP'
@@ -75,8 +81,8 @@ sha256sums=('SKIP'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '1b420e3cc2afca11154c672123f001cf03cd2b96be3baafd229f6ee7d752419e'
- '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
+ '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
+ '2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -106,6 +112,9 @@ prepare() {
git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino config --local submodule.ARMComputeLibrary.url "${srcdir}/ComputeLibrary"
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
+ git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"