summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-09-19 18:01:46 -0300
committerDaniel Bermond2024-09-19 18:01:46 -0300
commite6e5c0dcac74cc89a840c6127488eb801a055802 (patch)
tree3ad534c3ca0d29695461471b2ec71a4388b71530
parent54a94e4ff6c1502f62764d8b238eef4415b7c647 (diff)
downloadaur-e6e5c0dcac74cc89a840c6127488eb801a055802.tar.gz
Update to version 2024.4.0
-rw-r--r--.SRCINFO10
-rw-r--r--010-openvino-disable-werror.patch2
-rw-r--r--030-openvino-level-zero-disable-werror.patch11
-rw-r--r--PKGBUILD13
4 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9cff7ab23e9..660ff7dbfad6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvino
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications
- pkgver = 2024.3.0
+ pkgver = 2024.4.0
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
@@ -32,7 +32,7 @@ pkgbase = openvino
conflicts = intel-openvino
replaces = intel-openvino
options = !emptydirs
- source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.3.0
+ source = git+https://github.com/openvinotoolkit/openvino.git#tag=2024.4.0
source = oneDNN-openvinotoolkit::git+https://github.com/openvinotoolkit/oneDNN.git
source = git+https://github.com/herumi/xbyak.git
source = git+https://github.com/madler/zlib.git
@@ -63,7 +63,8 @@ pkgbase = openvino
source = setupvars.sh
source = 010-openvino-disable-werror.patch
source = 020-openvino-use-protobuf-shared-libs.patch
- sha256sums = 148b0a39051e24e1e87811c2c7177baa0505d2261817ad4db04ec2ce9d1cb5c2
+ source = 030-openvino-level-zero-disable-werror.patch
+ sha256sums = 556f335d199fb4c3dcd919f27eeca120eafc1814f0f4d42f2b1b8e681bc136e4
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -92,7 +93,8 @@ pkgbase = openvino
sha256sums = SKIP
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
- sha256sums = 0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132
+ sha256sums = c12e827abec2de978ab22f0c7667ebd632fb551e54aecbeade0cff1491dae3f3
sha256sums = 9c10b6d9cc6ba4722fae449f401875c538d5aa544d89edf3260fe766f946dbb8
+ sha256sums = 51dc09683a319f9a939369d47d6752b41fea61737e6886a5814fc75f3dc1cef1
pkgname = openvino
diff --git a/010-openvino-disable-werror.patch b/010-openvino-disable-werror.patch
index 2a168ec344d8..9f764b5742a8 100644
--- a/010-openvino-disable-werror.patch
+++ b/010-openvino-disable-werror.patch
@@ -1,6 +1,6 @@
--- a/src/plugins/intel_gpu/CMakeLists.txt
+++ b/src/plugins/intel_gpu/CMakeLists.txt
-@@ -46,10 +46,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
+@@ -53,10 +53,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
add_subdirectory(thirdparty)
include(thirdparty/cmake/rapidjson.cmake)
diff --git a/030-openvino-level-zero-disable-werror.patch b/030-openvino-level-zero-disable-werror.patch
new file mode 100644
index 000000000000..ac3ac80d1bcc
--- /dev/null
+++ b/030-openvino-level-zero-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -130,7 +130,7 @@ if(NOT MSVC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fpermissive")
+ endif()
+ if(NOT CMAKE_CXX_COMPILER_ID STREQUAL IntelLLVM)
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Werror -Wnon-virtual-dtor")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wnon-virtual-dtor")
+ endif()
+ endif()
+
diff --git a/PKGBUILD b/PKGBUILD
index d6360c1edf4e..d6e37bada2c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino
-pkgver=2024.3.0
+pkgver=2024.4.0
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications'
arch=('x86_64')
@@ -55,8 +55,9 @@ source=("git+https://github.com/openvinotoolkit/openvino.git#tag=${pkgver}"
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
- '020-openvino-use-protobuf-shared-libs.patch')
-sha256sums=('148b0a39051e24e1e87811c2c7177baa0505d2261817ad4db04ec2ce9d1cb5c2'
+ '020-openvino-use-protobuf-shared-libs.patch'
+ '030-openvino-level-zero-disable-werror.patch')
+sha256sums=('556f335d199fb4c3dcd919f27eeca120eafc1814f0f4d42f2b1b8e681bc136e4'
'SKIP'
'SKIP'
'SKIP'
@@ -85,8 +86,9 @@ sha256sums=('148b0a39051e24e1e87811c2c7177baa0505d2261817ad4db04ec2ce9d1cb5c2'
'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
- '9c10b6d9cc6ba4722fae449f401875c538d5aa544d89edf3260fe766f946dbb8')
+ 'c12e827abec2de978ab22f0c7667ebd632fb551e54aecbeade0cff1491dae3f3'
+ '9c10b6d9cc6ba4722fae449f401875c538d5aa544d89edf3260fe766f946dbb8'
+ '51dc09683a319f9a939369d47d6752b41fea61737e6886a5814fc75f3dc1cef1')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -125,6 +127,7 @@ prepare() {
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"
patch -d openvino -Np1 -i "${srcdir}/020-openvino-use-protobuf-shared-libs.patch"
+ patch -d openvino/src/plugins/intel_npu/thirdparty/level-zero -Np1 -i "${srcdir}/030-openvino-level-zero-disable-werror.patch"
}
build() {