summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2024-04-26 22:01:38 -0300
committerDaniel Bermond2024-04-26 22:01:38 -0300
commit07330e6632e5ccf1eb115b8b8a164d172b56be83 (patch)
tree3e80af7a1c6946b26850991f502ee4a97ea6462b
parentd7927ca351b9222c8cc64b053b3418f5ce60ef21 (diff)
downloadaur-07330e6632e5ccf1eb115b8b8a164d172b56be83.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO15
-rw-r--r--010-openvino-disable-werror.patch2
-rw-r--r--020-openvino-use-protobuf-shared-libs.patch2
-rw-r--r--PKGBUILD19
4 files changed, 30 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f72633b1013..382a950cdcdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvino-git
pkgdesc = A toolkit for developing artificial inteligence and deep learning applications (git version)
- pkgver = 2023.3.0.r875.g17bf1f6d841
+ pkgver = 2024.1.0.r209.g4655dd6ce3f
pkgrel = 1
url = https://docs.openvinotoolkit.org/
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = openvino-git
depends = onetbb
optdepends = intel-compute-runtime: for Intel GPU plugin
optdepends = ocl-icd: for Intel GPU plugin
+ optdepends = level-zero-loader: for Intel NPU plugin
optdepends = snappy: for tensorflow frontend
optdepends = protobuf: for tensorflow, paddle and onnx frontends
optdepends = python: for Python API
@@ -56,6 +57,10 @@ pkgbase = openvino-git
source = git+https://github.com/google/snappy.git
source = git+https://github.com/ARM-software/ComputeLibrary.git
source = git+https://github.com/openvinotoolkit/mlas.git
+ source = git+https://github.com/oneapi-src/level-zero.git
+ source = git+https://github.com/intel/level-zero-npu-extensions.git
+ source = git+https://github.com/openvinotoolkit/telemetry.git
+ source = git+https://github.com/libxsmm/libxsmm.git
source = openvino.conf
source = setupvars.sh
source = 010-openvino-disable-werror.patch
@@ -82,9 +87,13 @@ pkgbase = openvino-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af
sha256sums = e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c
- sha256sums = edb5f6a15e3bf8e46f8ee0dc8aa81e78e3d75d1776478664c7179bb8a79f735f
- sha256sums = 17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a
+ sha256sums = 0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132
+ sha256sums = 2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb
pkgname = openvino-git
diff --git a/010-openvino-disable-werror.patch b/010-openvino-disable-werror.patch
index 9adf433a6297..2a168ec344d8 100644
--- a/010-openvino-disable-werror.patch
+++ b/010-openvino-disable-werror.patch
@@ -1,6 +1,6 @@
--- a/src/plugins/intel_gpu/CMakeLists.txt
+++ b/src/plugins/intel_gpu/CMakeLists.txt
-@@ -41,10 +41,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
+@@ -46,10 +46,6 @@ set(INCLUDE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/include")
add_subdirectory(thirdparty)
include(thirdparty/cmake/rapidjson.cmake)
diff --git a/020-openvino-use-protobuf-shared-libs.patch b/020-openvino-use-protobuf-shared-libs.patch
index eb6341f2870f..b72bd88db4ff 100644
--- a/020-openvino-use-protobuf-shared-libs.patch
+++ b/020-openvino-use-protobuf-shared-libs.patch
@@ -1,6 +1,6 @@
--- a/thirdparty/dependencies.cmake
+++ b/thirdparty/dependencies.cmake
-@@ -307,7 +307,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
+@@ -318,7 +318,7 @@ if(ENABLE_OV_PADDLE_FRONTEND OR ENABLE_OV_ONNX_FRONTEND OR ENABLE_OV_TF_FRONTEND
# Note: Debian / Ubuntu / RHEL libprotobuf.a can only be used with -DBUILD_SHARED_LIBS=OFF
# because they are compiled without -fPIC
if(NOT DEFINED Protobuf_USE_STATIC_LIBS)
diff --git a/PKGBUILD b/PKGBUILD
index c621a95572bd..f2a03b415f3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# https://github.com/openvinotoolkit/openvino/issues/452#issuecomment-722941119
pkgname=openvino-git
-pkgver=2023.3.0.r875.g17bf1f6d841
+pkgver=2024.1.0.r209.g4655dd6ce3f
pkgrel=1
pkgdesc='A toolkit for developing artificial inteligence and deep learning applications (git version)'
arch=('x86_64')
@@ -13,6 +13,7 @@ license=('Apache-2.0')
depends=('pugixml' 'onetbb')
optdepends=('intel-compute-runtime: for Intel GPU plugin'
'ocl-icd: for Intel GPU plugin'
+ 'level-zero-loader: for Intel NPU plugin'
'snappy: for tensorflow frontend'
'protobuf: for tensorflow, paddle and onnx frontends'
'python: for Python API'
@@ -47,6 +48,10 @@ source=('git+https://github.com/openvinotoolkit/openvino.git'
'git+https://github.com/google/snappy.git'
'git+https://github.com/ARM-software/ComputeLibrary.git'
'git+https://github.com/openvinotoolkit/mlas.git'
+ 'git+https://github.com/oneapi-src/level-zero.git'
+ 'git+https://github.com/intel/level-zero-npu-extensions.git'
+ 'git+https://github.com/openvinotoolkit/telemetry.git'
+ 'git+https://github.com/libxsmm/libxsmm.git'
'openvino.conf'
'setupvars.sh'
'010-openvino-disable-werror.patch'
@@ -73,10 +78,14 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'335a55533ab26bd1f63683921baf33b8e8e3f2732a94554916d202ee500f90af'
'e5024ad3382f285fe63dc58faca379f11a669bbe9f5d90682c59ad588aab434c'
- 'edb5f6a15e3bf8e46f8ee0dc8aa81e78e3d75d1776478664c7179bb8a79f735f'
- '17417f7193e94c7df32242c71d650d8beda2dadea8b05db131a7731a56e9c84a')
+ '0bbf46bef304dea08b318d1ffd564735b19e1afb6c0f41c98d216824cc630132'
+ '2329bb09c80ce44ae622da9d318d246b237e3a4d259d12f6b8920a249ec994bb')
export GIT_LFS_SKIP_SMUDGE='1'
@@ -106,6 +115,10 @@ prepare() {
git -C openvino config --local submodule.thirdparty/snappy.url "${srcdir}/snappy"
git -C openvino config --local submodule.ARMComputeLibrary.url "${srcdir}/ComputeLibrary"
git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/mlas.url "${srcdir}/mlas"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero.url "${srcdir}/level-zero"
+ git -C openvino config --local submodule.src/plugins/intel_npu/thirdparty/level-zero-ext.url "${srcdir}/level-zero-npu-extensions"
+ git -C openvino config --local submodule.thirdparty/telemetry.url "${srcdir}/telemetry"
+ git -C openvino config --local submodule.src/plugins/intel_cpu/thirdparty/libxsmm.url "${srcdir}/libxsmm"
git -C openvino -c protocol.file.allow='always' submodule update
patch -d openvino -Np1 -i "${srcdir}/010-openvino-disable-werror.patch"