summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2019-02-19 22:48:52 +0100
committerNicola Murino2019-02-19 22:48:52 +0100
commitcc7f4f7aa8608790e62597e59d32151788faa60f (patch)
tree1db7d4a53241d6d30c77f9f6f9a1d21efa2f399a
parenta0ccb3d7454066051b4bfa852eafc23168fcf2d0 (diff)
downloadaur-cc7f4f7aa8608790e62597e59d32151788faa60f.tar.gz
Update to 2.4.7-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
2 files changed, 29 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b2f5c6cd1eb..919ef0f3529a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
-# Generated by mksrcinfo v8
-# Fri May 25 11:18:37 UTC 2018
pkgbase = openvpn-openssl-1.0
pkgdesc = An easy-to-use, robust and highly configurable VPN (Virtual Private Network) (build against openssl-1.0)
- pkgver = 2.4.6
+ pkgver = 2.4.7
pkgrel = 1
url = http://openvpn.net/index.php/open-source.html
arch = i686
arch = x86_64
license = custom
+ makedepends = git
makedepends = systemd
depends = openssl-1.0
depends = lzo
depends = iproute2
- depends = libsystemd
+ depends = systemd-libs
depends = pkcs11-helper
optdepends = easy-rsa: easy CA and certificate handling
+ optdepends = pam: authenticate via PAM
provides = openvpn
conflicts = openvpn
- source = https://swupdate.openvpn.net/community/releases/openvpn-2.4.6.tar.gz
- source = https://swupdate.openvpn.net/community/releases/openvpn-2.4.6.tar.gz.asc
- sha256sums = 738dbd37fcf8eb9382c53628db22258c41ba9550165519d9200e8bebaef4cbe2
+ source = git+git://github.com/OpenVPN/openvpn.git#tag=v2.4.7
sha256sums = SKIP
pkgname = openvpn-openssl-1.0
diff --git a/PKGBUILD b/PKGBUILD
index 99971906cb68..b19cfc16ab48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,28 +3,32 @@
pkgname=openvpn-openssl-1.0
_pkgname=openvpn
-pkgver=2.4.6
+pkgver=2.4.7
pkgrel=1
pkgdesc='An easy-to-use, robust and highly configurable VPN (Virtual Private Network) (build against openssl-1.0)'
arch=('i686' 'x86_64')
url='http://openvpn.net/index.php/open-source.html'
-depends=('openssl-1.0' 'lzo' 'iproute2' 'libsystemd' 'pkcs11-helper')
+depends=('openssl-1.0' 'lzo' 'iproute2' 'systemd-libs' 'pkcs11-helper')
conflicts=('openvpn')
provides=('openvpn')
-optdepends=('easy-rsa: easy CA and certificate handling')
-makedepends=('systemd')
+optdepends=('easy-rsa: easy CA and certificate handling'
+ 'pam: authenticate via PAM')
+makedepends=('git' 'systemd')
license=('custom')
-validpgpkeys=('F554A3687412CFFEBDEFE0A312F5F7B42F2B01E7') # OpenVPN - Security Mailing List <security@openvpn.net>
-source=("https://swupdate.openvpn.net/community/releases/openvpn-${pkgver}.tar.gz"{,.asc})
-sha256sums=('738dbd37fcf8eb9382c53628db22258c41ba9550165519d9200e8bebaef4cbe2'
- 'SKIP')
+source=("git+git://github.com/OpenVPN/openvpn.git#tag=v${pkgver}")
+sha256sums=('SKIP')
-build() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+prepare() {
+ cd "${srcdir}"/${_pkgname}
+
+ autoreconf -i
+}
- export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+build() {
+ mkdir "${srcdir}"/build
+ cd "${srcdir}"/build
- ./configure \
+ "${srcdir}"/${_pkgname}/configure \
--prefix=/usr \
--sbindir=/usr/bin \
--enable-iproute2 \
@@ -36,13 +40,13 @@ build() {
}
check() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+ cd "${srcdir}"/build
make check
}
package() {
- cd "${srcdir}"/${_pkgname}-${pkgver}
+ cd "${srcdir}"/build
# Install openvpn
make DESTDIR="${pkgdir}" install
@@ -50,14 +54,16 @@ package() {
# Create empty configuration directories
install -d -m0750 -g 90 "${pkgdir}"/etc/openvpn/{client,server}
- # Install examples
- install -d -m0755 "${pkgdir}"/usr/share/openvpn
- cp -r sample/sample-config-files "${pkgdir}"/usr/share/openvpn/examples
-
# Install license
install -d -m0755 "${pkgdir}"/usr/share/licenses/openvpn/
ln -sf /usr/share/doc/openvpn/{COPYING,COPYRIGHT.GPL} "${pkgdir}"/usr/share/licenses/openvpn/
+ cd "${srcdir}"/${_pkgname}
+
+ # Install examples
+ install -d -m0755 "${pkgdir}"/usr/share/openvpn
+ cp -r sample/sample-config-files "${pkgdir}"/usr/share/openvpn/examples
+
# Install contrib
for FILE in $(find contrib -type f); do
case "$(file --brief --mime-type "${FILE}")" in
@@ -66,4 +72,3 @@ package() {
esac
done
}
-