summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-02-07 15:49:27 +0700
committerKonstantin Shalygin2019-02-07 15:49:27 +0700
commit608b66cf5ef7eb486820500a41460ea6348315ef (patch)
treed8820ffb0e4a46b3a0f4d95fad0f59ba9c9e5704
parent7f2557fcf1a91a2a4730c3a1b47f5e8510bc6575 (diff)
downloadaur-608b66cf5ef7eb486820500a41460ea6348315ef.tar.gz
Now project have tarball, disable git.
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD14
3 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51d7ef20bd6d..d653836de224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Feb 7 03:43:13 UTC 2019
+# Thu Feb 7 08:47:57 UTC 2019
pkgbase = openvpn-otp
pkgdesc = This plugin adds support for TOTP and HOTP tokens (like Google Authenticator) for OpenVPN.
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/evgeny-gridasov/openvpn-otp
arch = any
license = GPL
- makedepends = git
makedepends = openssl
depends = openvpn
- source = openvpn-otp::git+https://github.com/evgeny-gridasov/openvpn-otp
- sha256sums = SKIP
+ source = https://github.com/evgeny-gridasov/openvpn-otp/archive/v1.0.tar.gz
+ md5sums = 3ff2b8f9cc054ccac31f99e9ee704f67
pkgname = openvpn-otp
diff --git a/.gitignore b/.gitignore
index c88e6f3f37e8..7c6927b4669a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
pkg/*
src/*
*.tar.*
-openvpn-otp/*
diff --git a/PKGBUILD b/PKGBUILD
index 4e0465cb8a29..5e8df7b7d622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname='openvpn-otp'
pkgver='1.0'
-pkgrel='2'
+pkgrel='3'
pkgdesc='This plugin adds support for TOTP and HOTP tokens (like Google Authenticator) for OpenVPN.'
arch=('any')
url="https://github.com/evgeny-gridasov/${pkgname}"
license=('GPL')
depends=('openvpn')
-source=("${pkgname}::git+${url}")
-makedepends=('git' 'openssl')
-sha256sums=('SKIP')
+source=("${url}/archive/v${pkgver}.tar.gz")
+makedepends=('openssl')
+md5sums=('3ff2b8f9cc054ccac31f99e9ee704f67')
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./autogen.sh
./configure \
--prefix="/usr" \
@@ -22,11 +22,11 @@ prepare() {
}
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
}