summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislaw Datskevich2015-06-08 22:25:19 +0300
committerStanislaw Datskevich2015-06-08 22:25:19 +0300
commite3fca31d53a95788642197be721a9460f8650220 (patch)
tree0f76dd3830f23427e78ac00e4ebcc59a3f16d0e7
downloadaur-e3fca31d53a95788642197be721a9460f8650220.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
-rw-r--r--openvpn.install9
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b5678ba4682
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = openvpn-pkcs11
+ pkgdesc = An easy-to-use, robust, and highly configurable VPN (Virtual Private Network) with smartcard support
+ pkgver = 2.3.6
+ pkgrel = 3
+ url = http://openvpn.net/index.php/open-source.html
+ install = openvpn.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = openssl
+ depends = lzo
+ depends = iproute2
+ depends = pkcs11-helper-1.11
+ source = http://swupdate.openvpn.net/community/releases/openvpn-2.3.6.tar.gz
+ sha256sums = 7baed2ff39c12e1a1a289ec0b46fcc49ff094ca58b8d8d5f29b36ac649ee5b26
+
+pkgname = openvpn-pkcs11
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54d7073e6612
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Thomas Bächler <me a nek0 net>
+# Contributor: Thomas Bächler <thomas@archlinux.org>
+
+pkgname=openvpn-pkcs11
+pkgver=2.3.6
+pkgrel=3
+pkgdesc="An easy-to-use, robust, and highly configurable VPN (Virtual Private Network) with smartcard support"
+arch=(i686 x86_64)
+url="http://openvpn.net/index.php/open-source.html"
+depends=('openssl' 'lzo' 'iproute2' 'pkcs11-helper-1.11')
+license=('custom')
+install=openvpn.install
+source=(http://swupdate.openvpn.net/community/releases/openvpn-${pkgver}.tar.gz)
+sha256sums=('7baed2ff39c12e1a1a289ec0b46fcc49ff094ca58b8d8d5f29b36ac649ee5b26')
+
+build() {
+ cd "${srcdir}"/openvpn-$pkgver
+ CFLAGS="$CFLAGS -DPLUGIN_LIBDIR=\\\"/usr/lib/openvpn\\\"" ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --enable-password-save \
+ --mandir=/usr/share/man \
+ --enable-iproute2 \
+ --enable-pkcs11
+ make
+}
+
+package() {
+ cd "${srcdir}"/openvpn-$pkgver
+ # Install openvpn
+ make DESTDIR="${pkgdir}" install
+ install -d -m755 "${pkgdir}"/etc/openvpn
+ # Install examples
+ install -d -m755 "${pkgdir}"/usr/share/openvpn
+ cp -r sample/sample-config-files "${pkgdir}"/usr/share/openvpn/examples
+ # Install license
+ install -d -m755 "${pkgdir}"/usr/share/licenses/${pkgname}/
+ ln -sf /usr/share/doc/${pkgname}/{COPYING,COPYRIGHT.GPL} "${pkgdir}"/usr/share/licenses/${pkgname}/
+ # Install contrib
+ install -d -m755 "${pkgdir}"/usr/share/openvpn/contrib
+ cp -r contrib "${pkgdir}"/usr/share/openvpn
+}
+
diff --git a/openvpn.install b/openvpn.install
new file mode 100644
index 000000000000..317ff44b7474
--- /dev/null
+++ b/openvpn.install
@@ -0,0 +1,9 @@
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ if [ $(vercmp 2.3.2-1 $2) -ge 0 ]; then
+ echo ">>> easy-rsa has moved into its own package. Run:"
+ echo ">>> # pacman -S easy-rsa"
+ fi
+}
+