summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorByeonghoon Yoo2021-07-11 15:57:08 +0900
committerByeonghoon Yoo2021-07-11 15:57:08 +0900
commitcfcdcfed9d10bb562053c00abe83543ade4e3f7b (patch)
treec18c35a16cf3e1b9f34e3b126685284eec520c3d
parenta84e335e6cc0c1c2a565ac9ecf076c145270e40f (diff)
downloadaur-cfcdcfed9d10bb562053c00abe83543ade4e3f7b.tar.gz
Enable DCO
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2493422e4b46..8d57c3493d0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openvpn3
pkgdesc = OpenVPN 3 Linux client
pkgver = 13_beta
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/OpenVPN/openvpn3-linux
install = openvpn3.install
arch = any
@@ -13,6 +13,9 @@ pkgbase = openvpn3
makedepends = make
makedepends = gcc
makedepends = git
+ makedepends = libnl
+ makedepends = protobuf
+ makedepends = python-jinja
depends = glib2>=2.50
depends = jsoncpp>=0.10.5
depends = libcap-ng>=0.7.5
@@ -24,8 +27,10 @@ pkgbase = openvpn3
optdepends = mbedtls: mbed TLS version
optdepends = python-dbus
optdepends = python-gobject
+ optdepends = polkit>=0.105: for systemd-resolved integration
+ optdepends = tinyxml2>=2.1.0: for AWS-VPC integration
+ optdepends = tinyxml2: for AWS-VPC integration
source = git+https://github.com/OpenVPN/openvpn3-linux.git#tag=v13_beta
sha256sums = SKIP
pkgname = openvpn3
-
diff --git a/PKGBUILD b/PKGBUILD
index a35efed3d034..ef0e945324ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=openvpn3-linux
pkgname=openvpn3
pkgver=13_beta
-pkgrel=1
+pkgrel=2
pkgdesc='OpenVPN 3 Linux client'
arch=('any')
url="https://github.com/OpenVPN/$_pkgname"
@@ -12,9 +12,13 @@ license=('AGPL3')
depends=('glib2>=2.50' 'jsoncpp>=0.10.5' 'libcap-ng>=0.7.5' 'lz4>=1.7.3' 'util-linux-libs>=2.23.2')
optdepends=(
'python>=3.5' 'python-docutils' 'openssl: OpenSSL version' 'mbedtls: mbed TLS version'
- 'python-dbus' 'python-gobject'
+ 'python-dbus' 'python-gobject' 'polkit>=0.105: for systemd-resolved integration'
+ 'tinyxml2>=2.1.0: for AWS-VPC integration' 'tinyxml2: for AWS-VPC integration'
+)
+makedepends=(
+ 'pkgconf' 'autoconf' 'autoconf-archive' 'automake' 'make' 'gcc' 'git'
+ 'libnl' 'protobuf' 'python-jinja'
)
-makedepends=('pkgconf' 'autoconf' 'autoconf-archive' 'automake' 'make' 'gcc' 'git')
install="${pkgname}.install"
source=("git+https://github.com/OpenVPN/$_pkgname.git#tag=v${pkgver}")
sha256sums=('SKIP')
@@ -22,7 +26,7 @@ sha256sums=('SKIP')
build() {
cd "$_pkgname"
./bootstrap.sh
- ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var
+ ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var --enable-bash-completion --enable-dco
make -j $(nproc)
}
@@ -35,6 +39,5 @@ check() {
package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" install
- echo "$srcdir/$_pkgname/src/shell/bash-completion/openvpn3"
install -Dm644 "$srcdir/$_pkgname/src/shell/bash-completion/openvpn3" "$pkgdir/usr/share/bash-completion/completions/openvpn3"
}