summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Asbach2024-04-03 21:54:47 +0200
committerBenjamin Asbach2024-04-03 21:54:47 +0200
commited282a14e951b1d78abfc29bd5ff82ca3db50baa (patch)
tree14709a4e6d8d5681ac8f0a3ee32b586272e9476e
downloadaur-ed282a14e951b1d78abfc29bd5ff82ca3db50baa.tar.gz
Created initial package for `openvpn3-indicator`
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb465a98e62b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = openvpn3-indicator-git
+ pkgdesc = Simple GTK indicator GUI for OpenVPN 3 Linux
+ pkgver = r49.177f15a
+ pkgrel = 1
+ url = https://github.com/OpenVPN/openvpn3-indicator
+ arch = any
+ license = AGPL
+ depends = openvpn3
+ depends = libayatana-appindicator
+ depends = python-secretstorage
+ depends = python-setproctitle
+ source = openvpn3-indicator::git+https://github.com/OpenVPN/openvpn3-indicator.git
+ sha256sums = SKIP
+
+pkgname = openvpn3-indicator-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba83acf3bf6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Benjamin Asbach <archlinux-aur.${pkgname}@impl.it>
+
+_pkgname='openvpn3-indicator'
+pkgname="${_pkgname}-git"
+pkgver=r49.177f15a
+pkgrel=1
+pkgdesc='Simple GTK indicator GUI for OpenVPN 3 Linux'
+
+url='https://github.com/OpenVPN/openvpn3-indicator'
+arch=('any')
+license=('AGPL')
+depends=('openvpn3' 'libayatana-appindicator' 'python-secretstorage' 'python-setproctitle')
+source=("${_pkgname}::git+https://github.com/OpenVPN/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/"$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"/"$_pkgname"
+ make DESTDIR="$pkgdir" PREFIX="/usr" package
+}