summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2019-08-16 02:47:36 +0200
committerChristoph Haag2019-08-16 02:47:36 +0200
commit40db59cde8a54bdd272473c4fa78b4718bb719e0 (patch)
tree9c8d03160253de85686487674c219eb612285e1b
parent312d46199402323b095930a8c3b5352183936858 (diff)
downloadaur-40db59cde8a54bdd272473c4fa78b4718bb719e0.tar.gz
various updates
- Remove oculus-udev optedepend. SteamVR-OpenHMD should suggest this. - Remove vive-udev optdepend. The steam package contains Vive udev rules. - Use shorter patch url for pull request 594 (fixes segfault in examples due to wrong define) - Add pull 1177: Fixes driver sample build, will be in next openvr upstream update - Add vulkan-headers makedepends per comment - Make steam optdepends description friendlier - build libopenvr_api.so from source instead of using Valve's prebuilt library
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bbf869e066f..3cd3b963f723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,31 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
- pkgver = 1.6.10.r0.gd9cffe2
+ pkgver = .1.6.10b.r0.g52065df
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
license = custom
makedepends = git
makedepends = cmake
+ makedepends = vulkan-headers
makedepends = qt5-base
depends = libgl
depends = sdl2
depends = glew
- optdepends = oculus-udev: Udev rule to make the rift sensors usable to the "plugdev" group
- optdepends = steam: For SteamVR (Duh)
- optdepends = vive-udev: Udev rule to make the Vive sensors usable to the "plugdev" group
+ optdepends = steam: SteamVR must be installed through Steam, also contains vive udev rules
provides = openvr
options = !strip
options = staticlibs
source = git+https://github.com/ValveSoftware/openvr.git
- source = https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch
source = 0001-also-add-pragma-pack-around-VRControllerState_t.patch
source = remove-openvrpaths-check.diff
+ source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/594.patch
+ source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1177.patch
md5sums = SKIP
- md5sums = 7350517830b1a0038d30c6ad33b4bb39
md5sums = 8a9379f8cdf9a38f21942f46378714a5
md5sums = 904a532900792e7273702a9b45d304f2
+ md5sums = 7350517830b1a0038d30c6ad33b4bb39
+ md5sums = 8aaa5723852e5ee81ba910235743fde2
pkgname = openvr-git
diff --git a/PKGBUILD b/PKGBUILD
index 24b614e8f94e..1ad6a3ba4e38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
pkgname=openvr-git
-pkgver=1.6.10.r0.gd9cffe2
+pkgver=.1.6.10b.r0.g52065df
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
url="https://github.com/ValveSoftware/openvr"
license=('custom')
depends=('libgl' 'sdl2' 'glew')
-optdepends=('oculus-udev: Udev rule to make the rift sensors usable to the "plugdev" group'
- 'steam: For SteamVR (Duh)'
- 'vive-udev: Udev rule to make the Vive sensors usable to the "plugdev" group')
-makedepends=('git' 'cmake' 'qt5-base') #qt5 for the overlayexample
+optdepends=('steam: SteamVR must be installed through Steam, also contains vive udev rules')
+makedepends=('git' 'cmake' 'vulkan-headers' 'qt5-base') #qt5 for the overlayexample
provides=("openvr")
options=('!strip' 'staticlibs')
source=("git+https://github.com/ValveSoftware/openvr.git"
- 'https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch'
'0001-also-add-pragma-pack-around-VRControllerState_t.patch'
- 'remove-openvrpaths-check.diff')
+ 'remove-openvrpaths-check.diff'
+ 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/594.patch'
+ 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1177.patch')
md5sums=('SKIP'
- '7350517830b1a0038d30c6ad33b4bb39'
'8a9379f8cdf9a38f21942f46378714a5'
- '904a532900792e7273702a9b45d304f2')
+ '904a532900792e7273702a9b45d304f2'
+ '7350517830b1a0038d30c6ad33b4bb39'
+ '8aaa5723852e5ee81ba910235743fde2')
pkgver() {
cd "$srcdir/openvr"
@@ -31,26 +31,33 @@ pkgver() {
prepare() {
cd "$srcdir/openvr"
- git apply ../0fa21ba17748efcca1816536e27bdca70141b074.patch #https://github.com/ValveSoftware/openvr/pull/594
git apply ../0001-also-add-pragma-pack-around-VRControllerState_t.patch
git apply ../remove-openvrpaths-check.diff
+ git apply ../594.patch
+ git apply ../1177.patch
- sed -i '/driver_sample/d' "$srcdir"/openvr/samples/CMakeLists.txt
}
build() {
#export CXX=clang++
#export CC=clang
+ # Remove Valve's prebuilt libs so they are built from source.
+ # Valve's build prebuilt libs contains internal API symbols.
+ # See: https://github.com/ValveSoftware/openvr/issues/425
+ rm -rf bin
+
+ # build static libopenvr_api.a, in case want to statically link their apps
cd openvr
cmake -DBUILD_SHARED=0 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
make
- # Valve's build of libopenvr_api.so contains symbols that have no source code available
- # See: https://github.com/ValveSoftware/openvr/issues/425
- #cmake -DBUILD_SHARED=1 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
- #make
+ # libopenvr_api.so
+ cmake -DBUILD_SHARED=1 -DCMAKE_INSTALL_PREFIX=/usr/ -DCMAKE_BUILD_TYPE=Release .
+ make
+ # hellovr_vulkan and hellovr_opengl
+ # Example apps that are useful to test SteamVR with both graphics APIs.
cd samples
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/ -Wno-dev .
make
@@ -59,7 +66,7 @@ build() {
package() {
cd openvr
make install DESTDIR="$pkgdir"
- install -m 555 bin/linux64/libopenvr_api.so "$pkgdir/usr/lib"
+ install -m 555 bin/linux64/libopenvr_api.a "$pkgdir/usr/lib"
# Install examples
install -d "$pkgdir/usr/bin"
@@ -67,6 +74,7 @@ package() {
cd samples
+ #TODO: fix openvr upstream source to look in proper place for resources
install -m 755 "bin/linux64/hellovr_vulkan" "$pkgdir/usr/bin"
for shader in "bin/shaders/"*.spv
do
@@ -77,9 +85,7 @@ package() {
install -m 755 "bin/hellovr_actions.json" "$pkgdir/usr/"
install -m 755 "bin/linux64/helloworldoverlay" "$pkgdir/usr/bin"
install -m 755 "bin/linux64/tracked_camera_openvr_sample" "$pkgdir/usr/bin"
- #TODO: fix source code to look in proper place
install -m 755 "bin/cube_texture.png" "$pkgdir/usr/"
-
}
# vim:set ts=2 sw=2 et: