summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2021-03-12 12:31:18 +0100
committerChristoph Haag2021-03-12 12:31:18 +0100
commit7fc22be4d823ac8e9a01bdd2b6b5d10c7b762dbd (patch)
tree279863f643145ccefaad3d12e9386930e5d951c6
parent3ffb55ee3e0750b2005a74fa0468bb3626874785 (diff)
downloadaur-7fc22be4d823ac8e9a01bdd2b6b5d10c7b762dbd.tar.gz
update to 1.16.8
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Add-include-stdarg.h-to-strtools_public.cpp.patch25
-rw-r--r--0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch12
-rw-r--r--PKGBUILD14
4 files changed, 47 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59dd33db68e3..2e679a0fba61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors.
- pkgver = 1.14.15.r1.ge3d3756
+ pkgver = 1.16.8.r0.g4c85abc
pkgrel = 1
url = https://github.com/ValveSoftware/openvr
arch = x86_64
@@ -21,11 +21,15 @@ pkgbase = openvr-git
source = 0002-samples-cmake-Remove-OpenVR-paths-check.patch
source = 0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch
source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch
+ source = https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1524.patch
+ source = 0001-Add-include-stdarg.h-to-strtools_public.cpp.patch
md5sums = SKIP
- md5sums = 79543abcb2f86a8dcfcc942dc32c4090
+ md5sums = 4aa6ee8199d86dde2a563b4495f41a53
md5sums = d3dc9d20967362a2e92e3fb1c7f82b57
md5sums = e68ff412ff73b1ca75f8b17ab6c7069a
md5sums = bd5a473153106325233f00b3f35c46d8
+ md5sums = 30e13170804c6d6756d74fa1ee7bdcb0
+ md5sums = ac790ec12a558931895504f1ca92c364
pkgname = openvr-git
diff --git a/0001-Add-include-stdarg.h-to-strtools_public.cpp.patch b/0001-Add-include-stdarg.h-to-strtools_public.cpp.patch
new file mode 100644
index 000000000000..8d23cf188732
--- /dev/null
+++ b/0001-Add-include-stdarg.h-to-strtools_public.cpp.patch
@@ -0,0 +1,25 @@
+From 75e74794ecfd8cf5f0ba0086eca59ab6041e18c5 Mon Sep 17 00:00:00 2001
+From: Christoph Haag <christoph.haag@collabora.com>
+Date: Fri, 12 Mar 2021 12:29:02 +0100
+Subject: [PATCH] Add #include <stdarg.h> to strtools_public.cpp
+
+Required for va_start and va_end
+---
+ src/vrcommon/strtools_public.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/vrcommon/strtools_public.cpp b/src/vrcommon/strtools_public.cpp
+index 3193f7e..10b8419 100644
+--- a/src/vrcommon/strtools_public.cpp
++++ b/src/vrcommon/strtools_public.cpp
+@@ -10,6 +10,7 @@
+ #include <functional>
+ #include <locale>
+ #include <codecvt>
++#include <stdarg.h>
+
+ #if defined( _WIN32 )
+ #include <windows.h>
+--
+2.30.2
+
diff --git a/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
index d56dd74bb798..0565d9bd296a 100644
--- a/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
+++ b/0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch
@@ -1,4 +1,4 @@
-From cef0756d3c26317c453132ddfad08cb814c339d5 Mon Sep 17 00:00:00 2001
+From 833a92c6f00c2178436008c1e1a7d6614165a56a Mon Sep 17 00:00:00 2001
From: Christoph Haag <christoph.haag@collabora.com>
Date: Wed, 8 Aug 2018 01:06:29 +0200
Subject: [PATCH] openvr_capi: Add pragma pack around VRControllerState_t.
@@ -9,10 +9,10 @@ See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
1 file changed, 8 insertions(+)
diff --git a/headers/openvr_capi.h b/headers/openvr_capi.h
-index 6feb2c6..d263914 100644
+index 13c71fc..3c32c59 100644
--- a/headers/openvr_capi.h
+++ b/headers/openvr_capi.h
-@@ -2051,6 +2051,11 @@ typedef struct VRControllerAxis_t
+@@ -2202,6 +2202,11 @@ typedef struct VRControllerAxis_t
float y;
} VRControllerAxis_t;
@@ -24,7 +24,7 @@ index 6feb2c6..d263914 100644
typedef struct VRControllerState_t
{
uint32_t unPacketNum;
-@@ -2058,6 +2063,9 @@ typedef struct VRControllerState_t
+@@ -2209,6 +2214,9 @@ typedef struct VRControllerState_t
uint64_t ulButtonTouched;
struct VRControllerAxis_t rAxis[5]; //struct vr::VRControllerAxis_t[5]
} VRControllerState_t;
@@ -32,8 +32,8 @@ index 6feb2c6..d263914 100644
+#pragma pack( pop )
+#endif
- typedef struct VRBoneTransform_t
+ typedef struct CameraVideoStreamFrameHeader_t
{
--
-2.25.1
+2.30.2
diff --git a/PKGBUILD b/PKGBUILD
index 31b3d867e2f5..5a1c900c37ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=openvr-git
-pkgver=1.14.15.r1.ge3d3756
+pkgver=1.16.8.r0.g4c85abc
pkgrel=1
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors."
arch=('x86_64')
@@ -16,12 +16,16 @@ source=("git+https://github.com/ValveSoftware/openvr.git"
'0002-samples-cmake-Remove-OpenVR-paths-check.patch' # samples/cmake: Remove OpenVR paths check.
'0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch' # Use correct C++11 definition for vsprintf_s https://github.com/ValveSoftware/openvr/pull/594
'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1178.patch' # Add ability to build with system installed jsoncpp
+ 'https://patch-diff.githubusercontent.com/raw/ValveSoftware/openvr/pull/1524.patch' # fix broken 1.6.8 build https://github.com/ValveSoftware/openvr/issues/1525
+ '0001-Add-include-stdarg.h-to-strtools_public.cpp.patch' # missing include for va_start and va_end
)
md5sums=('SKIP'
- '79543abcb2f86a8dcfcc942dc32c4090'
+ '4aa6ee8199d86dde2a563b4495f41a53'
'd3dc9d20967362a2e92e3fb1c7f82b57'
'e68ff412ff73b1ca75f8b17ab6c7069a'
- 'bd5a473153106325233f00b3f35c46d8')
+ 'bd5a473153106325233f00b3f35c46d8'
+ '30e13170804c6d6756d74fa1ee7bdcb0'
+ 'ac790ec12a558931895504f1ca92c364')
install_examples=false
@@ -38,7 +42,9 @@ prepare() {
"../0001-openvr_capi-Add-pragma-pack-around-VRControllerState.patch" \
"../0002-samples-cmake-Remove-OpenVR-paths-check.patch" \
"../0003-samples-compat-Use-correct-definition-for-vsprintf_s.patch" \
- "../1178.patch"
+ "../1178.patch" \
+ "../1524.patch" \
+ "../0001-Add-include-stdarg.h-to-strtools_public.cpp.patch"
do
echo "Applying $i"
git apply "$i"