summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2018-08-08 01:12:01 +0200
committerChristoph Haag2018-08-08 01:12:01 +0200
commitd8c247d74628cdeca8bd427362d25e2a409007ef (patch)
tree73311b93664d9cbd1c43b521fbca37d85800e7d6
parent50f9aea5999924f5ac33458239d08b40a6b6131e (diff)
downloadaur-d8c247d74628cdeca8bd427362d25e2a409007ef.tar.gz
add another patch
-rw-r--r--.SRCINFO6
-rw-r--r--0001-also-add-pragma-pack-around-VRControllerState_t.patch39
-rw-r--r--PKGBUILD9
3 files changed, 49 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa86bed57b1c..9d3b8ee74722 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Jul 31 22:21:17 UTC 2018
+# Tue Aug 7 23:11:59 UTC 2018
pkgbase = openvr-git
pkgdesc = API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam.
pkgver = 1.0.16.r0.g6aacebd
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ValveSoftware/openvr
arch = x86_64
license = custom
@@ -23,10 +23,12 @@ pkgbase = openvr-git
source = https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch
source = https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch
source = 0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch
+ source = 0001-also-add-pragma-pack-around-VRControllerState_t.patch
md5sums = SKIP
md5sums = 7350517830b1a0038d30c6ad33b4bb39
md5sums = dfb4306bb93633e467862cd8990e6e79
md5sums = 97bc5ddeee3f2005afdc32b689711131
+ md5sums = 8a9379f8cdf9a38f21942f46378714a5
pkgname = openvr-git
diff --git a/0001-also-add-pragma-pack-around-VRControllerState_t.patch b/0001-also-add-pragma-pack-around-VRControllerState_t.patch
new file mode 100644
index 000000000000..daedc8a56f5c
--- /dev/null
+++ b/0001-also-add-pragma-pack-around-VRControllerState_t.patch
@@ -0,0 +1,39 @@
+From 1fd28b735d8abcc3fde9a4f5493407b5c0fcb91e Mon Sep 17 00:00:00 2001
+From: Christoph Haag <christoph.haag@collabora.com>
+Date: Wed, 8 Aug 2018 01:06:29 +0200
+Subject: [PATCH] also add pragma pack around VRControllerState_t
+
+See https://github.com/ValveSoftware/SteamVR-for-Linux/issues/35
+---
+ headers/openvr_capi.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/headers/openvr_capi.h b/headers/openvr_capi.h
+index 66da364..97906eb 100644
+--- a/headers/openvr_capi.h
++++ b/headers/openvr_capi.h
+@@ -1206,6 +1206,11 @@ typedef struct VRControllerAxis_t
+ float y;
+ } VRControllerAxis_t;
+
++#if defined(__linux__) || defined(__APPLE__)
++// This structure was originally defined mis-packed on Linux, preserved for
++// compatibility.
++#pragma pack( push, 4 )
++#endif
+ typedef struct VRControllerState_t
+ {
+ uint32_t unPacketNum;
+@@ -1213,6 +1218,9 @@ typedef struct VRControllerState_t
+ uint64_t ulButtonTouched;
+ struct VRControllerAxis_t rAxis[5]; //struct vr::VRControllerAxis_t[5]
+ } VRControllerState_t;
++#if defined(__linux__) || defined(__APPLE__)
++#pragma pack( pop )
++#endif
+
+ typedef struct Compositor_OverlaySettings
+ {
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 419832f5c5c2..9ac6c0c2dd4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=openvr-git
pkgver=1.0.16.r0.g6aacebd
-pkgrel=1
+pkgrel=2
pkgdesc="API and runtime that allows access to VR hardware from multiple vendors. Contains API and samples. The runtime is under SteamVR in Tools on Steam."
arch=('x86_64')
url="https://github.com/ValveSoftware/openvr"
@@ -16,11 +16,13 @@ options=('!strip' 'staticlibs')
source=("git+https://github.com/ValveSoftware/openvr.git"
'https://github.com/ValveSoftware/openvr/commit/0fa21ba17748efcca1816536e27bdca70141b074.patch'
'https://github.com/ValveSoftware/openvr/commit/4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch'
- '0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch')
+ '0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch'
+ '0001-also-add-pragma-pack-around-VRControllerState_t.patch')
md5sums=('SKIP'
'7350517830b1a0038d30c6ad33b4bb39'
'dfb4306bb93633e467862cd8990e6e79'
- '97bc5ddeee3f2005afdc32b689711131')
+ '97bc5ddeee3f2005afdc32b689711131'
+ '8a9379f8cdf9a38f21942f46378714a5')
pkgver() {
cd "$srcdir/openvr"
@@ -34,6 +36,7 @@ prepare() {
git apply ../0fa21ba17748efcca1816536e27bdca70141b074.patch #https://github.com/ValveSoftware/openvr/pull/594
git apply ../4f9149928e29e9f92e6d8dc39f984d1a557a42b3.patch #https://github.com/ValveSoftware/openvr/pull/805
git apply ../0001-fix-VREvent_Data_t-union-in-c-header-and-add-pragma-.patch # autogenerated, so no pull request
+ git apply ../0001-also-add-pragma-pack-around-VRControllerState_t.patch
}
build() {