aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuji Hagiwara2022-09-18 19:00:16 +0900
committerYuji Hagiwara2022-09-18 19:00:16 +0900
commitea129c1fd7aaff0c6ae2f6ab02b1f68ab80c9c82 (patch)
treea478b7b902937ea348cf29df046c73b3021de5aa
downloadaur-ea129c1fd7aaff0c6ae2f6ab02b1f68ab80c9c82.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD55
-rw-r--r--README.md2
-rw-r--r--openvswitch.install13
-rw-r--r--openvswitch.tmpfiles1
-rw-r--r--ovs-vswitchd.service15
-rw-r--r--ovsdb-server.service7
8 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5643d1a7aa7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = openvswitch-dpdk
+ pkgdesc = Production Quality, Multilayer Open Virtual Switch, with DPDK feature
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://openvswitch.org
+ install = openvswitch.install
+ arch = x86_64
+ license = APACHE
+ makedepends = python-six
+ depends = openssl
+ depends = libcap-ng
+ depends = dpdk
+ optdepends = python-six
+ provides = openvswitch
+ options = debug
+ source = http://openvswitch.org/releases/openvswitch-3.0.0.tar.gz
+ source = openvswitch.tmpfiles
+ source = ovsdb-server.service
+ source = ovs-vswitchd.service
+ sha256sums = fa9da2c21c5fcb01f43e83ab55a5c80659bdc84e655f70eed4154215533f199e
+ sha256sums = e8dc21e50fc886bfd6aa55991bdb3cb66907e11b071045452bb12de01a3ecbd9
+ sha256sums = fa2412b81c77921418131a4f6fd38956f50ffcc7b908ec91f94d3607a05d060b
+ sha256sums = 412a8d9a2d71f61b915d5e29c0ba44baae7770f564d885f99460b27a4cf1d398
+
+pkgname = openvswitch-dpdk
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..da2f5640ef32
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/**
+src/**
+openvswitch-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1671d6fe43cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Yuji Hagiwara <yuuzi41 at gmail dot com>
+
+pkgname=openvswitch-dpdk
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Production Quality, Multilayer Open Virtual Switch, with DPDK feature"
+url="http://openvswitch.org"
+license=('APACHE')
+arch=(x86_64)
+install=openvswitch.install
+source=("http://openvswitch.org/releases/openvswitch-$pkgver.tar.gz"
+ openvswitch.tmpfiles
+ ovsdb-server.service
+ ovs-vswitchd.service)
+depends=('openssl' 'libcap-ng' 'dpdk')
+makedepends=('python-six')
+optdepends=('python-six')
+provides=('openvswitch')
+options=('debug')
+sha256sums=('fa9da2c21c5fcb01f43e83ab55a5c80659bdc84e655f70eed4154215533f199e'
+ 'e8dc21e50fc886bfd6aa55991bdb3cb66907e11b071045452bb12de01a3ecbd9'
+ 'fa2412b81c77921418131a4f6fd38956f50ffcc7b908ec91f94d3607a05d060b'
+ '412a8d9a2d71f61b915d5e29c0ba44baae7770f564d885f99460b27a4cf1d398')
+
+prepare() {
+ cd "$srcdir/openvswitch-$pkgver"
+ sed -i \
+ -e 's|$(sysconfdir)/bash_completion.d|/usr/share/bash-completion/completions|g' \
+ Makefile.am
+}
+
+build() {
+ cd "$srcdir/openvswitch-$pkgver"
+ ./boot.sh
+ export CFLAGS="$CFLAGS -ffat-lto-objects"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-rundir=/run/openvswitch \
+ --sbindir=/usr/bin \
+ --with-dpdk=static \
+ PYTHON=/usr/bin/python2
+ make
+}
+
+package() {
+ cd "$srcdir/openvswitch-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 "$srcdir"/openvswitch.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/openvswitch.conf"
+ install -Dm0644 "$srcdir"/ovsdb-server.service "$pkgdir/usr/lib/systemd/system/ovsdb-server.service"
+ install -Dm0644 "$srcdir"/ovs-vswitchd.service "$pkgdir/usr/lib/systemd/system/ovs-vswitchd.service"
+ install -dm0755 "$pkgdir/etc/openvswitch"
+ rm -rf "$pkgdir"/run
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..89904fde57ba
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+This is a fork from https://github.com/archlinux/svntogit-community/tree/packages/openvswitch/trunk
+Thanks.
diff --git a/openvswitch.install b/openvswitch.install
new file mode 100644
index 000000000000..fa6fb40f20e2
--- /dev/null
+++ b/openvswitch.install
@@ -0,0 +1,13 @@
+post_install() {
+ if [[ ! -f etc/openvswitch/conf.db ]]; then
+ cmd=(ovsdb-tool create
+ etc/openvswitch/conf.db
+ usr/share/openvswitch/vswitch.ovsschema)
+ printf "Running: %s\n" "${cmd[*]}"
+ "${cmd[@]}"
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/openvswitch.tmpfiles b/openvswitch.tmpfiles
new file mode 100644
index 000000000000..f99f19f89fb2
--- /dev/null
+++ b/openvswitch.tmpfiles
@@ -0,0 +1 @@
+d /run/openvswitch 0770 root root -
diff --git a/ovs-vswitchd.service b/ovs-vswitchd.service
new file mode 100644
index 000000000000..58791b5dfd9a
--- /dev/null
+++ b/ovs-vswitchd.service
@@ -0,0 +1,15 @@
+[Unit]
+Description = Open vSwitch Daemon
+Documentation = man:ovs-vswitchd
+Wants = network.target
+Before = network.target NetworkManager.service
+Requires = ovsdb-server.service
+After = ovsdb-server.service
+
+[Service]
+ExecStartPre = /sbin/modprobe openvswitch
+PIDFile = /run/openvswitch/ovs-vswitchd.pid
+ExecStart = /usr/sbin/ovs-vswitchd --pidfile=/run/openvswitch/ovs-vswitchd.pid
+
+[Install]
+WantedBy = multi-user.target
diff --git a/ovsdb-server.service b/ovsdb-server.service
new file mode 100644
index 000000000000..6bcb76bb2fa2
--- /dev/null
+++ b/ovsdb-server.service
@@ -0,0 +1,7 @@
+[Unit]
+Description = Open vSwitch Database Server
+Documentation = man:ovsdb-server
+
+[Service]
+PIDFile=/run/openvswitch/ovsdb-server.pid
+ExecStart=/usr/sbin/ovsdb-server --remote=punix:/var/run/openvswitch/db.sock --pidfile=/run/openvswitch/ovsdb-server.pid