summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Staal2018-02-23 15:03:11 +0100
committerJens Staal2018-02-23 15:03:11 +0100
commitaa0b0dbbc915f52cc19b2cea41a5aaa0dab986ed (patch)
tree9406cf2adfe152cd305f5f037ac24c12aaeda8f2
parentdc17aa9cb1873fd9b8903043b83fef99f18ff47f (diff)
downloadaur-aa0b0dbbc915f52cc19b2cea41a5aaa0dab986ed.tar.gz
now using master .zip file from github
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD67
-rw-r--r--owsetenv.sh15
3 files changed, 33 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a52782d09a35..c4d3b78e3338 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-# Generated by mksrcinfo v8
-# Thu Dec 10 03:47:48 UTC 2015
pkgbase = openwatcom-v2
pkgdesc = The Open Watcom Fortran/C/C++ compiler, binary distribution -V2 fork
pkgver = 2.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/open-watcom
- arch = any
+ arch = x86_64
license = custom:OWPL-1
- noextract = open-watcom-2_0-c-linux-x86
- noextract = open-watcom-2_0-f77-linux-x86
options = !strip
- source = http://downloads.sourceforge.net/project/openwatcom/current-build/open-watcom-2_0-c-linux-x86
- source = http://downloads.sourceforge.net/project/openwatcom/current-build/open-watcom-2_0-f77-linux-x86
- md5sums = SKIP
+ source = https://github.com/open-watcom/travis-ci-ow-builds/archive/master.zip
+ source = owsetenv.sh
md5sums = SKIP
+ md5sums = fed7651420d74b7d89302c5ef0a9d8a8
pkgname = openwatcom-v2
diff --git a/PKGBUILD b/PKGBUILD
index 33034fe24581..64132e578743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,32 @@
# Mantainer: Jens Staal <staal1978@gmail.com>
# Contributor : ackalker
-# Modified from open_watcom: Felix Stirlitz <m.p.isaev@yandex.com>
-# adjust the configuration below to change options
pkgname=openwatcom-v2
pkgver=2.0
-pkgrel=3
+pkgrel=4
pkgdesc="The Open Watcom Fortran/C/C++ compiler, binary distribution -V2 fork"
-arch=('any')
+arch=('x86_64')
#url="http://www.openwatcom.org"
url="https://github.com/open-watcom"
license=('custom:OWPL-1')
-source=( 'http://downloads.sourceforge.net/project/openwatcom/current-build/open-watcom-2_0-c-linux-x86'
- 'http://downloads.sourceforge.net/project/openwatcom/current-build/open-watcom-2_0-f77-linux-x86')
-noextract=( 'open-watcom-2_0-c-linux-x86' 'open-watcom-2_0-f77-linux-x86' )
+source=(
+'https://github.com/open-watcom/travis-ci-ow-builds/archive/master.zip'
+'owsetenv.sh'
+)
#md5sums change frequently since it is a snapshot. If it fails, download manually and check md5sum
-#sums can be found at:
-#http://optimate.dl.sourceforge.net/project/openwatcom/current-build/sums.md5
-#any automatic way to import those?
-md5sums=('SKIP' 'SKIP')
+md5sums=('SKIP' 'fed7651420d74b7d89302c5ef0a9d8a8')
options=(!strip)
build() {
- chmod +x ./open-watcom-2_0-f77-linux-x86
- chmod +x ./open-watcom-2_0-c-linux-x86
+ ls
}
package() {
-#all possible cross compile targets enabled by default
- _tmpnam="$(mktemp /tmp/options.$$.XXXXXXXXX)"
- sed -e 's/#.*$//g' >"$_tmpnam" <<EOF
-ms=true # small memory model libraries
-mm=true # medium memory model libraries
-mc=true # compact memory model libraries
-ml=true # large memory model libraries
-mh=true # huge memory model libraries
-doshost=false # DOS host binaries
-os2host=false # OS/2 host binaries
-dostarg=true # DOS target libraries
-os2targ=true # OS/2 target libraries
-nlmtarg=true # Novell Netware target
-rdoshost=false # RDOS host binaries
-rdostarg=true # RDOS target libraries
-lnxhost=true # Linux host binaries
-lnxtarg=true # Linux target libraries
-winhost=false # Windows host binaries
-wnthost=false # Windows NT host binaries
-wintarg=true # Windows target libraries
-wnttarg=true # Windows NT target libraries
-tools16=true # 16-bit tools
-samples=true # Samples
-helpfiles=false # Help files
-win16_helpfiles=false # Win16 help files
-win32_helpfiles=false # Windows NT help files
-htmlhelp_helpfiles=false # CHM help files
-whelp_helpfiles=false # WHELP help files
-os2_helpfiles=false # OS/2 help files
-pdf_helpfiles=true # PDF help files
-rtsource=true # Runtime library source
-3r=true # Register calling convention libraries
-3s=true # Stack calling convention libraries
-cplusplus=true # C++ support
-EOF
- TERM=linux ./open-watcom-2_0-f77-linux-x86 -i -dDstDir="$pkgdir/opt/watcom" -dOWDir="/opt/watcom" -f="$_tmpnam"
- TERM=linux ./open-watcom-2_0-c-linux-x86 -i -dDstDir="$pkgdir/opt/watcom" -dOWDir="/opt/watcom" -f="$_tmpnam"
- install -d "$pkgdir/usr/share/licenses/watcom"
+ mkdir -p "${pkgdir}/opt"
+ mv -f "${srcdir}/travis-ci-ow-builds-master" "${pkgdir}/opt/watcom"
+ install -d "${pkgdir}/usr/share/licenses/watcom"
install -Dm644 "$pkgdir/opt/watcom/license.txt" "$pkgdir/usr/share/licenses/watcom/license.txt"
- _pkgdirsane="$(echo "$pkgdir" | sed -e 's,[\[^$.+*\\?],\\&,g')"
- sed -i -e "s,$_pkgdirsane,," "$pkgdir/opt/watcom/owsetenv.sh"
- rm -f "$_tmpnam"
+
+ cp "${srcdir}/owsetenv.sh" ${pkgdir}/opt/watcom/
msg "correct permissions for header directories"
chmod -R 755 $pkgdir/opt/watcom/{h,lh}
diff --git a/owsetenv.sh b/owsetenv.sh
new file mode 100644
index 000000000000..0d9c7bd638f4
--- /dev/null
+++ b/owsetenv.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+export WATCOM = /opt/watcom
+export PATH = $WATCOM/binl64:$WATCOM/binl:$PATH
+export EDPATH = $WATCOM/eddat
+
+#these variables change based on compilation target
+#defaults are set for native compilation
+export INCLUDE = $WATCOM/lh
+# export LIB =
+
+
+
+
+