summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-02-11 20:01:25 +0100
committerFabioLolix2018-02-11 20:01:25 +0100
commitda8906dcb6ee55b4995a694f0fa8dfb75765b745 (patch)
tree670034cf249e74d7c0056e621e123511f70e12f0
downloadaur-openwmail-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b46cd83faf3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = openwmail-bin
+ pkgdesc = Desktop client for Gmail and Google Inbox, community run Fork of wmail
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/openwmail/openwmail
+ arch = x86_64
+ license = MPL
+ depends = libnotify
+ depends = gconf
+ depends = alsa-lib
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = gtk2
+ provides = openwmail
+ conflicts = openwmail
+ source = https://github.com/openWMail/openWMail/releases/download/v1.0.0/openWMail_1-0-0_Linux_x86_64.deb
+ md5sums = d84ceea682905b58531c43f5962317fb
+
+pkgname = openwmail-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b04396437a64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: Aaron Ogle <aaron@geekgonecrazy.com>
+
+pkgname=openwmail-bin
+pkgver=1.0.0
+_pkgverdash=1-0-0
+pkgrel=1
+pkgdesc="Desktop client for Gmail and Google Inbox, community run Fork of wmail"
+arch=('x86_64')
+license=('MPL')
+depends=('libnotify'
+ 'gconf'
+ 'alsa-lib'
+ 'libxss'
+ 'libxtst'
+ 'nss'
+ 'gtk2')
+provides=('openwmail')
+conflicts=('openwmail')
+url="https://github.com/openwmail/openwmail"
+source=("https://github.com/openWMail/openWMail/releases/download/v${pkgver}/openWMail_${_pkgverdash}_Linux_x86_64.deb")
+md5sums=('d84ceea682905b58531c43f5962317fb')
+PKGEXT='.pkg.tar'
+
+package() {
+ bsdtar -xf data.tar.gz -C "${pkgdir}"
+
+ install -d "${pkgdir}/usr/bin"
+ chmod +x ${pkgdir}/opt/openwmail/openWMail
+ ln -s /opt/openwmail/openWMail ${pkgdir}/usr/bin
+
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}/
+ mv ${pkgdir}/opt/openwmail/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+ mv ${pkgdir}/opt/openwmail/vendor-licenses/LICENSES{.chromium.html,.vendor} ${pkgdir}/usr/share/licenses/${pkgname}/
+
+ rm -r ${pkgdir}/opt/openwmail/vendor-licenses/
+ rm ${pkgdir}/opt/openwmail/openwmail.desktop
+}
+