summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2022-06-01 21:42:28 +0100
committerWorMzy Tykashi2022-06-01 21:42:28 +0100
commit3525c389a0e666e164fbcd07d8bdff3aaf0dd4be (patch)
tree5c3093c62e9931a41d013001138a2b812a3c21a5
parentca606ec509711bd2afd17be6464689f207e357ee (diff)
downloadaur-3525c389a0e666e164fbcd07d8bdff3aaf0dd4be.tar.gz
Fix manpage installation again
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61fb3da9eac3..b3ce3b923c44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openxcom-extended
pkgdesc = An extended version of the open-source reimplementation of X-COM (OXCE)
pkgver = 7.5.15
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://openxcom.org/forum/index.php/topic,5251.0.html
install = openxcom-extended.install
diff --git a/PKGBUILD b/PKGBUILD
index d44b740e50de..f68931db83bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ epoch=1
# Repo doesn't use tags, so set which commit this version corresponds to in
# https://github.com/MeridianOXC/OpenXcom/commits/oxce-plus/src/version.h
_commit=efdfce4ace49b3101d8580af006d6aa2a51fbe9b
-pkgrel=1
+pkgrel=2
pkgdesc="An extended version of the open-source reimplementation of X-COM (OXCE)"
arch=('i686' 'x86_64')
url="https://openxcom.org/forum/index.php/topic,5251.0.html"
@@ -18,22 +18,24 @@ optdepends=('openxcom-data-steam: pacman-tracked X-COM data files from Steam'
provides=('openxcom' 'openxcom-git')
conflicts=('openxcom')
install="${pkgname}.install"
-source=(openxcom-extended::git+"https://github.com/MeridianOXC/OpenXcom.git#commit=${_commit}")
+source=(${pkgname}::git+"https://github.com/MeridianOXC/OpenXcom.git#commit=${_commit}")
md5sums=('SKIP')
sha1sums=('SKIP')
prepare() {
- mkdir -p openxcom-extended/build
- sed -i 's:openxcom.6 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man6):openxcom.6 DESTINATION ${CMAKE_INSTALL_PREFIX}/share/man/man6):' openxcom-extended/docs/CMakeLists.txt
+ mkdir -p ${pkgname}/build
}
build() {
- cd openxcom-extended/build
+ cd ${pkgname}/build
cmake -DCMAKE_INSTALL_PREFIX="/usr" -DTARGET_PLATFORM="linux" -DCMAKE_BUILD_TYPE="None" -DDEV_BUILD="Off" ..
make
}
package() {
- cd openxcom-extended/build
+ cd ${pkgname}/build
make DESTDIR="${pkgdir}" install
+
+ # Fix manpage location
+ install -Dm644 "${srcdir}/${pkgname}/docs/openxcom.6" "${pkgdir}/usr/share/man/man6/openxcom.6"
}