summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-08 13:35:14 +0100
committerWorMzy Tykashi2015-06-08 13:35:14 +0100
commitaff33eb4d443d3b9c19859f0f4136363ade7a790 (patch)
treed5279c175698f63369b4e55a4c4815d0968e4e29
downloadaur-aff33eb4d443d3b9c19859f0f4136363ade7a790.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD67
-rw-r--r--openxcom-git.install19
-rw-r--r--openxcom.sh4
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6716ab2b8982
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = openxcom-git
+ pkgver = 1.0_1037_g894263b
+ pkgrel = 1
+ url = http://openxcom.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = xmlto
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ makedepends = doxygen
+ makedepends = sdl_mixer
+ makedepends = sdl_gfx
+ makedepends = sdl_image
+ makedepends = sdl
+ makedepends = yaml-cpp51
+ makedepends = libgl
+ makedepends = gcc-libs
+ makedepends = glibc
+ makedepends = boost
+ makedepends = glu
+ makedepends = cmake
+ makedepends = hicolor-icon-theme
+ source = git+https://github.com/SupSuper/OpenXcom.git
+ source = openxcom.sh
+ sha256sums = SKIP
+ sha256sums = e30fa48364c66e510825f18e406381811ddffb78b5e8641e6a147b613f36cdc0
+
+pkgname = openxcom-git
+ pkgdesc = An open-source reimplementation of the famous X-COM game (git-version)
+ install = openxcom-git.install
+ depends = sdl_mixer
+ depends = sdl_gfx
+ depends = sdl_image
+ depends = sdl
+ depends = yaml-cpp51
+ depends = libgl
+ depends = gcc-libs
+ depends = glibc
+ depends = hicolor-icon-theme
+ optdepends = openxcom-data-steam: pacman-tracked X-COM data files from Steam
+ provides = openxcom
+ conflicts = openxcom
+
+pkgname = openxcom-docs-git
+ pkgdesc = Documentation for the open-source reimplementation of the famous X-COM game (git-version)
+ arch = any
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..269fecb47b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributor: Stefan Karner <stefan.karner at student.tuwien.ac.at>
+
+pkgbase=openxcom-git
+pkgname=('openxcom-git' 'openxcom-docs-git')
+_gitname=OpenXcom
+pkgver=1.0_1037_g894263b
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://openxcom.org/"
+license=('GPL3')
+makedepends=('git' 'xmlto' 'docbook-xml' 'docbook-xsl' 'doxygen' 'sdl_mixer'
+ 'sdl_gfx' 'sdl_image' 'sdl' 'yaml-cpp51' 'libgl' 'gcc-libs' 'glibc'
+ 'boost' 'glu' 'cmake' 'hicolor-icon-theme')
+source=(git+"https://github.com/SupSuper/${_gitname}.git"
+ "openxcom.sh")
+sha256sums=('SKIP'
+ 'e30fa48364c66e510825f18e406381811ddffb78b5e8641e6a147b613f36cdc0')
+
+pkgver() {
+ cd $_gitname
+ git describe --tags | sed -e 's:v::' -e 's:-:_:g'
+}
+
+# By default, openxcom builds with -Werror, which causes the build to fail if a compiler
+# warning is encountered. Uncomment the following prepare function to turn this off.
+#prepare() {
+# cd $_gitname
+# sed -i 's:werror=yes:werror=no:' configure.ac
+#}
+
+build() {
+ cd $_gitname
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DYAMLCPP_LIBRARY="/opt/yaml-cpp51/lib/libyaml-cpp.so.0.5.1" -DYAMLCPP_INCLUDE_DIR="/opt/yaml-cpp51/include"
+ make
+
+ # Make documentation
+ cd docs
+ make doxygen
+}
+
+package_openxcom-git() {
+ pkgdesc="An open-source reimplementation of the famous X-COM game (git-version)"
+ depends=('sdl_mixer' 'sdl_gfx' 'sdl_image' 'sdl' 'yaml-cpp51' 'libgl' 'gcc-libs'
+ 'glibc' 'hicolor-icon-theme')
+ optdepends=('openxcom-data-steam: pacman-tracked X-COM data files from Steam')
+ provides=('openxcom')
+ conflicts=('openxcom')
+ install="${pkgname}.install"
+
+ cd $_gitname
+
+ make DESTDIR="$pkgdir" install
+
+ # Move actual binary
+ mv "$pkgdir/usr/bin/openxcom" "$pkgdir/usr/share/openxcom/common/openxcom"
+ # Install wrapper script
+ install -Dm755 "$srcdir/openxcom.sh" "$pkgdir/usr/bin/openxcom"
+}
+
+package_openxcom-docs-git() {
+ pkgdesc="Documentation for the open-source reimplementation of the famous X-COM game (git-version)"
+ arch=('any')
+ cd $_gitname/docs
+ install -dm755 "$pkgdir/usr/share/doc/openxcom/"
+ cp -a html "$pkgdir/usr/share/doc/openxcom/"
+}
diff --git a/openxcom-git.install b/openxcom-git.install
new file mode 100644
index 000000000000..f994f567bd2d
--- /dev/null
+++ b/openxcom-git.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo " OpenXcom requires the original X-COM resources."
+ echo " You need the following subfolders from the original game:"
+ echo " GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UFOINTRO, UNITS"
+ echo " Copy those subfolders to one of the following locations:"
+ echo " - /usr/share/openxcom/UFO"
+ echo " - <user home folder>/.local/share/openxcom/UFO"
+
+ post_upgrade
+}
+
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_remove() {
+ post_upgrade
+}
diff --git a/openxcom.sh b/openxcom.sh
new file mode 100644
index 000000000000..e1b10c348355
--- /dev/null
+++ b/openxcom.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/env bash
+
+export LD_LIBRARY_PATH=/opt/yaml-cpp51/lib:$LD_LIBRARY_PATH
+exec /usr/share/openxcom/common/openxcom $@