summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2024-02-28 15:28:04 +0000
committerWorMzy Tykashi2024-02-28 15:28:04 +0000
commit4d4ad3146f54107577c10ba369cde98b0888410c (patch)
treec64f034cfdc12ea04e1a3273a3252f0919858636
parentc64bfb75aa664b45f7b4a76c376100f51e27ba15 (diff)
downloadaur-openxcom-tftd-data-steam.tar.gz
Include data patch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aee0ae3cbcfa..1680e6c9806e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = openxcom-tftd-data-steam
pkgdesc = X-COM data files (from steam) for openxcom (Terror From The Deep)
- pkgver = 1
- pkgrel = 2
+ pkgver = 2
+ pkgrel = 1
url = https://steamcommunity.com/app/7650
arch = any
- license = custom
+ license = LicenseRef-custom
depends = openxcom-git
provides = openxcom-tftd-data
noextract = filelist
@@ -1130,6 +1130,7 @@ pkgbase = openxcom-tftd-data-steam
noextract = XBITS.TAB
noextract = ZOMBIE.PCK
noextract = ZOMBIE.TAB
+ noextract = universal-patch-tftd.zip
source = filelist
source = copier.sh
source = localfile://ADLIB.CAT
@@ -2253,6 +2254,7 @@ pkgbase = openxcom-tftd-data-steam
source = localfile://XBITS.TAB
source = localfile://ZOMBIE.PCK
source = localfile://ZOMBIE.TAB
+ source = https://openxcom.org/download/extras/universal-patch-tftd.zip
md5sums = b46ab1beeadcac8c14dd61d69d57865a
md5sums = 9e860e05a11e42b34f8ba4d790ba8bfc
md5sums = f41e41471074a14d1572f822d0e7824e
@@ -3376,6 +3378,6 @@ pkgbase = openxcom-tftd-data-steam
md5sums = d95ad283b92cbbc955c7195c2e13721b
md5sums = e127b9197ffbd28a0562e4bfc5e6a68b
md5sums = aec879064656ab80efcdbf82ad39411e
+ md5sums = a6af59cb753655036f1cdac72aae2210
pkgname = openxcom-tftd-data-steam
-
diff --git a/PKGBUILD b/PKGBUILD
index fc58fcdab951..8dbd4665fca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,12 +26,12 @@
pkgname=openxcom-tftd-data-steam
-pkgver=1
-pkgrel=2
+pkgver=2
+pkgrel=1
pkgdesc="X-COM data files (from steam) for openxcom (Terror From The Deep)"
arch=(any)
url="https://steamcommunity.com/app/7650"
-license=('custom')
+license=('LicenseRef-custom')
depends=('openxcom-git')
provides=('openxcom-tftd-data')
DLAGENTS+=('localfile::/usr/bin/echo "Could not find %u. Use the copier.sh script to copy them into this directory"')
@@ -1159,6 +1159,7 @@ source=(
"localfile://XBITS.TAB"
"localfile://ZOMBIE.PCK"
"localfile://ZOMBIE.TAB"
+ "https://openxcom.org/download/extras/universal-patch-tftd.zip"
)
noextract=(
"filelist"
@@ -2284,6 +2285,7 @@ noextract=(
"XBITS.TAB"
"ZOMBIE.PCK"
"ZOMBIE.TAB"
+ "universal-patch-tftd.zip"
)
md5sums=('b46ab1beeadcac8c14dd61d69d57865a'
@@ -3408,7 +3410,8 @@ md5sums=('b46ab1beeadcac8c14dd61d69d57865a'
'0882c01f3d76dfb9b431da1f2403c73b'
'd95ad283b92cbbc955c7195c2e13721b'
'e127b9197ffbd28a0562e4bfc5e6a68b'
- 'aec879064656ab80efcdbf82ad39411e')
+ 'aec879064656ab80efcdbf82ad39411e'
+ 'a6af59cb753655036f1cdac72aae2210')
package() {
@@ -4535,4 +4538,11 @@ package() {
install -Dm644 "${srcdir}/XBITS.TAB" "${_destdir}/TERRAIN/XBITS.TAB"
install -Dm644 "${srcdir}/ZOMBIE.PCK" "${_destdir}/UNITS/ZOMBIE.PCK"
install -Dm644 "${srcdir}/ZOMBIE.TAB" "${_destdir}/UNITS/ZOMBIE.TAB"
+
+ # extract patch
+ bsdtar -C "${_destdir}" -xf "${srcdir}/universal-patch-tftd.zip"
+
+ # fix perms (borked by patch extraction)
+ find "${_destdir}" -type d -exec chmod 755 {} \;
+ find "${_destdir}" -type f -exec chmod 644 {} \;
}