summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author007exe2019-11-03 09:09:11 +0300
committer007exe2019-11-03 09:09:11 +0300
commitcc3edc18d02fc4a9093f7649709fe55f73c490d0 (patch)
tree0a6d9de6e969d372079f368d976870e590f2ceb1
downloadaur-cc3edc18d02fc4a9093f7649709fe55f73c490d0.tar.gz
release build 558
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD40
-rw-r--r--info.install20
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0441471372de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openxray
+ pkgdesc = Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)
+ pkgver = 1.6.02_558
+ pkgrel = 1
+ url = https://github.com/OpenXRay/xray-16
+ install = info.install
+ arch = x86_64
+ license = custom:Custom 3-сlause BSD
+ makedepends = gcc
+ makedepends = git
+ makedepends = cmake
+ makedepends = libglvnd
+ makedepends = libjpeg6-turbo
+ makedepends = ncurses
+ makedepends = pcre2
+ makedepends = pcre
+ depends = glew
+ depends = sdl2
+ depends = openal
+ depends = intel-tbb
+ depends = crypto++
+ depends = liblockfile
+ depends = freeimage
+ depends = libogg
+ depends = libtheora
+ depends = libvorbis
+ depends = lzo
+ depends = lzop
+ depends = libjpeg-turbo
+ conflicts = openxray-git
+ conflicts = openxray-dev
+ source = xray-16::git+https://github.com/OpenXRay/xray-16.git#tag=558
+ md5sums = SKIP
+
+pkgname = openxray
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff8775cb5ba8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: chip_exe
+# https://aur.archlinux.org/packages/openxray-git/
+# <openxray@yahoo.com>
+pkgname=openxray
+_tag=558
+pkgver=1.6.02_$_tag
+pkgrel=1
+pkgdesc="Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)"
+arch=('x86_64')
+url="https://github.com/OpenXRay/xray-16"
+license=('custom:Custom 3-сlause BSD')
+install="info.install"
+makedepends=(gcc git cmake libglvnd libjpeg6-turbo ncurses pcre2 pcre)
+depends=(glew sdl2 openal intel-tbb crypto++ liblockfile freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo)
+conflicts=(openxray-git openxray-dev)
+source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#tag=$_tag)
+md5sums=('SKIP')
+
+prepare(){
+cd "$srcdir/xray-16"
+git submodule init
+git submodule update
+}
+
+build() {
+ cd "$srcdir/xray-16"
+ rm -fr bin
+ mkdir "$srcdir/xray-16/bin"
+ cd "$srcdir/xray-16/bin"
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/xray-16/bin"
+ make DESTDIR="${pkgdir}/" install
+ mv "${pkgdir}/usr/games/" "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/licenses/$pkgname/"
+ cp "$srcdir/xray-16/License.txt" "${pkgdir}/usr/share/licenses/$pkgname/"
+}
diff --git a/info.install b/info.install
new file mode 100644
index 000000000000..c3d7905cfb9e
--- /dev/null
+++ b/info.install
@@ -0,0 +1,20 @@
+post_install() {
+
+ cat << EOF
+
+The OpenXRay project continues the unofficial support and development of the X-Ray 1.6.02 game engine. The original engine is used in the game S.T.A.L.K.E.R.: Call of Pripyat, released by GSC Game World.
+
+Attention!!! Keep in mind that this GSC Game World project is in no way authorized, and they remain the copyright holders of all source code.
+
+This package does not provide game resources, to start the game you will need the original game resources of a licensed copy of S.T.A.L.K.E.R .: Call of Pripyat.
+From the original licensed version of STALKER.: Call of Pripyat copy the following directories: levels, localization, mp, patches, resources to ~/.local/share/GSC/SCOP, you can also launch S.T.A.L.K.E.R.: Clear Sky for this you need directories as for S.T.A.L.K.E.R.: Call of Pripyat from the S.T.A.L.K.E.R.: Clear Sky distribution, remove the gamedata symlink and copy the /usr/share/openxray/gamedata/shaders/ directory to it. You can use resources from a physical DVD, GOG or Steam media.
+
+Attention!!! All directory and file names inside directories must be lowercase.
+
+You can also run fan modifications for the vanilla version of S.T.A.L.K.E.R.: Call of Pripyat, however, you may need to adapt them.
+
+EOF
+
+}
+
+