summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author007exe2019-08-17 16:24:14 +0300
committer007exe2019-08-17 16:24:14 +0300
commit475b459d98c0ceda16d29ab3999bab4a278337bf (patch)
treeb955c0018f91515b51cdddc8122ac8b10556162c
downloadaur-475b459d98c0ceda16d29ab3999bab4a278337bf.tar.gz
ver 1
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD35
-rw-r--r--info.install25
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22c1f0ffe505
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = openxray-git
+ pkgdesc = Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)
+ pkgver = 1.6.02_0117cf5
+ pkgrel = 1
+ url = https://github.com/OpenXRay/xray-16
+ install = info.install
+ arch = x86_64
+ license = unknown
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = glew
+ makedepends = libglvnd
+ makedepends = openal
+ makedepends = pugixml
+ makedepends = intel-tbb
+ makedepends = crypto++
+ makedepends = liblockfile
+ makedepends = freeimage
+ makedepends = freeimage
+ makedepends = libogg
+ makedepends = libtheora
+ makedepends = libvorbis
+ makedepends = lzo
+ makedepends = lzop
+ makedepends = libjpeg-turbo
+ makedepends = libjpeg6-turbo
+ makedepends = ncurses
+ makedepends = pcre2
+ makedepends = pcre
+ makedepends = sdl2
+ depends = glew
+ depends = sdl2
+ depends = openal
+ depends = intel-tbb
+ depends = crypto++
+ depends = liblockfile
+ depends = freeimage
+ depends = freeimage
+ depends = lua51
+ depends = libogg
+ depends = libtheora
+ depends = libvorbis
+ depends = lzo
+ depends = lzop
+ depends = libjpeg-turbo
+ source = xray-16::git+https://github.com/OpenXRay/xray-16.git#commit=0117cf5
+ md5sums = SKIP
+
+pkgname = openxray-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14614d101459
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=openxray-git
+_commit=0117cf5
+pkgver=1.6.02_$_commit
+pkgrel=1
+pkgdesc="Unofficial X-Ray Engine Linux port by OpenXRay team (Originally developed by GSC Game World)"
+arch=('x86_64')
+url="https://github.com/OpenXRay/xray-16"
+license=('unknown')
+install="info.install"
+makedepends=(gcc cmake glew libglvnd openal pugixml intel-tbb crypto++ liblockfile freeimage freeimage libogg libtheora libvorbis lzo lzop libjpeg-turbo libjpeg6-turbo ncurses pcre2 pcre sdl2)
+depends=(glew sdl2 openal intel-tbb crypto++ liblockfile freeimage freeimage lua51 libogg libtheora libvorbis lzo lzop libjpeg-turbo)
+source=(xray-16::git+https://github.com/OpenXRay/xray-16.git#commit=$_commit)
+md5sums=('SKIP')
+
+prepare(){
+cd "$srcdir/xray-16"
+git submodule init
+git submodule update
+}
+
+build() {
+ cd "$srcdir/xray-16"
+ rm -fr build
+ mkdir "$srcdir/xray-16/build"
+ cd "$srcdir/xray-16/build"
+ cmake ..
+ #cmake .. -DCMAKE_BUILD_TYPE=Debug
+ make -j$(nproc)
+}
+
+package() {
+ cd "$srcdir/xray-16/build"
+ make DESTDIR="$pkgdir/" install
+ mv $pkgdir/usr/games/ $pkgdir/usr/bin
+}
diff --git a/info.install b/info.install
new file mode 100644
index 000000000000..b66e16990d33
--- /dev/null
+++ b/info.install
@@ -0,0 +1,25 @@
+post_install() {
+
+ cat << EOF
+
+The OpenXRay project continues the non-official support and development of the X-Ray 1.6.02 game engine. The original engine is used in the S.T.A.L.K.E.R.: Call of Pripyat game released by GSC Game World.
+
+Attention!!! Be advised that this project is not sanctioned by GSC Game World in any way – and they remain the copyright holders of all the original source code.
+
+This package does not provide game resources, to start the game you will need the original game resources of a licensed copy of S.T.A.L.K.E.R.: Call of Pripyat.
+From the original licensed version of S.T.A.L.K.E.R.: Call of Pripyat copy the following directories levels, localization, mp, patches, resources to ~ /.local/share/GSC/SCOP You can use the resources from a physical DVD media, GOG or Steam.
+
+Attention!!! All directory and file names inside directories must be lowercase.
+
+It is also possible to launch fan modifications for the vanilla version of S.T.A.L.K.E.R.: Call of Pripyat however, it may be necessary to adapt them.
+
+EOF
+
+}
+
+post_upgrade() {
+
+ post_install
+
+}
+